Browsing NFS shares *extremely* slow and hang Finder

Discussion in 'OS X Mountain Lion (10.8)' started by Fuzzb, Jan 2, 2013.

  1. Fuzzb macrumors member

    Joined:
    Nov 4, 2008
    #1
    I've got a problem with my 15" retina MacBook Pro when connecting to NFS shares exported from a Solaris 11.1 server. The problem I'm seeing is that connecting to the shares takes a long time, browsing the directory structure takes forever and the network shares disconnect intermittently. File transfers never complete and the Finder frequently hangs with the annoying beach ball that I haven't been plagued with since the time pre-SSD!

    I'm running OS X 10.8 with the latest updates from Apple and I've tried re-installing OS X 10.8 from scratch twice, erasing the disk beforehand and the problem still persists. I haven't installed any extra software apart from the base OS. I've also tried disabling the wireless card and using my Thunderbolt Display ethernet connection and the same problem still occurs.

    My wife has a 13" retina MacBook Pro, and I also have a Mac Mini, neither of which suffer the same problem. Connecting to NFS shares on either is lightning quick, and I'm able to browse the directory structures quickly and transfer files without any problems.

    If there was a problem with my Solaris server then I'd expect the same problem to happen on other clients, which is not happening. All the machines are set to acquire IP addresses via DHCP, and I have a local DNS server running. As far as I can tell, there are no differences in the network configurations on any of the machines.

    Does anyone have any ideas what might be causing this problem? I'm starting to pull my hair out on this one!
     
  2. Fuzzb thread starter macrumors member

    Joined:
    Nov 4, 2008
    #2
    I've just used NFS Manager to manually mount one of the NFS shares on my MacBook Pro, specifying the nolocks & rdirplus options and now I'm able to connect and browse the shares without any problems as I can do on my wife's MacBook Pro and Mac Mini.

    This raises the question: why do the other machines work fine with the default settings, without me having to specify the options above? Hrmmmm.
     
  3. Fuzzb thread starter macrumors member

    Joined:
    Nov 4, 2008
    #3
    Looks like James Gosling (of Java fame) had the same issue: NFS on Snow Leopard

    However, there is a huge problem with this: OS X does a phenominal amount of file locking (some would say, needlessly so) and has always been really sensitive to the configuration of locking on the NFS servers. So much so that if you randomly pick an NFS server in a large enterprise, true success is pretty unlikely. It'll succeed, but you'll keep getting messages indicating that the lock server is down, followed quickly by another message that the lock server is back up again. Even if you do get the NFS server tuned precisely the way that OS X wants it, performance sucks because of all the lock/unlock protocol requests that fly across the network. They clearly did something in Snow Leopard to aggravate this problem: it's now nasty enough to make NFS almost useless for me.

    Fortunately, there is a fix: just turn off network locking. You can do it by adding the "nolocks,locallocks" options in the advanced options field of the Disk Utility NFS mounting UI, but this is painful if you do a lot of them, and doesn't help at all with /net. You can edit /etc/auto_master to add these options to the /net entry, but it doesn't affect other mounts - however I do recommend deleting the hidefromfinder option in auto_master. If you want to fix every automount, edit /etc/autofs.conf and search for the line that starts with AUTOMOUNTD_MNTOPTS=. These options get applied on every mount. Add nolocks,locallocks and your world will be faster and happier after you reboot.
     

Share This Page