Browsing Speed is very slow in Macbook

Discussion in 'MacBook' started by dreamgood, Dec 27, 2008.

  1. dreamgood macrumors newbie

    Jul 2, 2008

    i am using this Mac book from around 8 months. one thing i don't understand is! it is very slow when i browse any thing with Browsers. i used Firefox and safari both.. but its the same

    i got another partition with XP. when i switch to XP the pages load very fast.i don't understand why.

    is thr any thing spl i got to change in the settings ? please help me with this.when ever my friends use my Mac they say its very slow :( normally with all applications(yahoo messenger,skype.....)its fast only with the Browsers its slow..

    Details of my macbook are....

    Model Name: MacBook
    Model Identifier: MacBook4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 2 GB
    Bus Speed: 800 MHz

    thanks.. greetings from spain :)
  2. Hellion macrumors member


    Feb 15, 2008
    South Florida
    Are you using wifi or ethernet? Try ethernet and see if you get same results. I know that for me, when I get slowdowns once every 2-3 months I reboot my router and everything is good again. Also, are you using bit torrent by chance? If so, uploading will SLOW the *(*& outta your browser speed....
  3. MSchmunk macrumors newbie

    Dec 27, 2008
    if you are using wifi try switching to ethernet. a direct connection through the ethernet cable should be a lot faster. you should be able to find a ethernet cable for about $10 dollars at any store (walmart, target, best buy, etc.).
  4. dreamgood thread starter macrumors newbie

    Jul 2, 2008
    i am using the Wifi and i reboot the router every day.. my router is in another room i think i cant use a cable from thr as we share the internet in the house.

    but i wonder why the page loading speeds in XP are faster than OSX ? with the same wifi and everything...
  5. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    You might try setting the DNS servers. Here are some good public DNS servers. You can set them in System Preferences>Network>Advanced>DNS.

Share This Page