BT Mighty Mouse in Boot Camp XP not working

Discussion in 'MacBook Pro' started by coledog, Oct 25, 2008.

  1. coledog macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Adirondacks
    #1
    Alright, I have one of the new MBPs (Late 2008) and I have Boot Camp utilized with XP. (Strictly for games)

    I had a Mighty Mouse (aka MM) from a Powermac G5 that I had been using with the OSX and XP sides, it was working perfectly!

    Now with the new MBP, in Boot Camp, the bluetooth configuration utility sees the MM and adds it, but it doesn't work...no cursor movement, plenty of cursing however.

    The MM just goes to sleep like it doesn't see the computer from its side! I had this working great a week ago and now with a new comp nothing wants to work. Are there some hidden drivers somewhere, some setting I somehow managed to set up previously?

    In any case...any help or agreement would be appreciated. I'll be calling Applecare tomorrow afternoon but I prefer all of you even to :apple:.

    (Mods, I posted this in the Windows on Mac forum also but didn't get much of a response, feel free to lock if I'm terribly violating.)
     
  2. Nate025 macrumors regular

    Joined:
    Oct 18, 2008
    #2
    I just paired my MM in Vista via Bluetooth, and am typing this in IE.

    I turned the mouse off, brought up the BT screen and turned on the mouse. I searched for devices and chose the mouse, previously setup in OSX. When it asked for a passkey I picked the "don't use one" option.

    After it completed and I closed the window, the mouse was still inactive. A new dialogue popped up in the system tray notifying me that a bluetooth device was trying to connect, this new window asked for a passkey. I tried clicking next and was denied, so out of the blue I entered 0000 and it paired! Try that. :)
     
  3. Vivid.Inferno macrumors 6502

    Vivid.Inferno

    Joined:
    Jul 28, 2008
    Location:
    Ottawa, ON
    #3
    It's the same with a bluetooth headset and a cell phone from the sounds of it. Whenever I try to connect a headset for the first time to my cell, it asks me for a passkey, and by default it's always 0000
     
  4. Nate025 macrumors regular

    Joined:
    Oct 18, 2008
    #4
    Yeah lucked out I guess. I've had other stuff, like cell phones, default to 0000 in the past, so I figured I'd give it a shot.

    It'd be nice if this information was given in the paper manual included in the box. :rolleyes:
     
  5. coledog thread starter macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Adirondacks
  6. MacNewby macrumors newbie

    Joined:
    Dec 7, 2008
    #6
    Mighty Mouse key 0000 and extra action required.

    So thank you all for the instructions.

    On my macbook pro 4.1 I also had to enter 0000.
    However, mouse still didn't work.

    So I went into control panel and into 'bluetooth devices'.
    In the 'devices' tab, the mouse was listed.
    After selecting it, select 'properties'.
    Select 'Services' tab.
    An entry pops up about drivers, this one was unchecked(!) in my case.
    After checking it, the mouse worked fine.

    Lars
     

Share This Page