BT Mighty Mouse stopped scrolling

dalvin200

macrumors 68040
Original poster
Mar 24, 2006
3,434
24
Nottingham, UK
so my wireless mighty mouse is not so mighty anymore :(P(

The scroll wheel seems knackered - nothing scrolls up or down, but i am still able to scroll sideways!! weird..

tried lots of things but still nothing.. in the end, a call to apple was in order who are going to send me a replacement!!

anyone else had this happen to them?
 

MattyMac

macrumors 68000
Oct 6, 2005
1,691
7
NJ/NYC
dalvin200 said:
so my wireless mighty mouse is not so mighty anymore :(P(

The scroll wheel seems knackered - nothing scrolls up or down, but i am still able to scroll sideways!! weird..

tried lots of things but still nothing.. in the end, a call to apple was in order who are going to send me a replacement!!

anyone else had this happen to them?
Sure you didn't have the scroll up down option disabled in system preferences??

...reallywierd.
 

dalvin200

macrumors 68040
Original poster
Mar 24, 2006
3,434
24
Nottingham, UK
MattyMac said:
Sure you didn't have the scroll up down option disabled in system preferences??

...reallywierd.
That was one of the many things I tried messing with - the system prefs..

re-paried mouse, tried all the settings in system prefs/mouse (ie, no scroll, vertical only, both etc..).. rebooting mac etc.. etc.. but none of them seemed to work :(

yeah, it is really weird.. and it's not like the scroll wheel is dirty or anything either..

oh well, lets hope the replacement is good!! hehe

having no vertical scrolling is VERY ANNOYING i can tell you that :)
 

bigandy

macrumors G3
Apr 30, 2004
8,852
0
Murka
It's a problem with wired ones too.

press down hard and push violently up and down for a while. usually solves it.

if not, open it up (not hard, and google for howtos), and clean the sensors.

it's because of grease on fingers. it's happened to mine, and almost everyone i know who has one, at some point.
 

dalvin200

macrumors 68040
Original poster
Mar 24, 2006
3,434
24
Nottingham, UK
bigandy said:
It's a problem with wired ones too.

press down hard and push violently up and down for a while. usually solves it.

if not, open it up (not hard, and google for howtos), and clean the sensors.

it's because of grease on fingers. it's happened to mine, and almost everyone i know who has one, at some point.
HA.. what do you know... IT WORKED!!!!! holy crap!!!
now do i cancel the replacement??