BT support on early 2011 MBP

Sanddoc

macrumors newbie
Original poster
Mar 12, 2019
15
0
Hi
I just really found this site today, and I have a few questions.
I installed Os Mojave on this machine, and except for 3 programs everything seems to be working.
1.. the video card and greying of the side bars and menu
2. No support for BT

has a patch or driver been written for the BT? I've searched the net but found nothing.
I'm not concered about the video card..
I can not update to 10.14.x not buy the system update or installing from a .dmg.
I could use any assistance.
Best
Dave
 

Honza1

macrumors 6502
Nov 30, 2013
436
143
US
You may be able to find some suggestions how to patch the driver to be usable for your old BT or copy driver from older OSX. Not sure.

If that does not work, buy BT dongle which is Mojave compatible (they are cheap $7 - $20) and plug that into USB port and you are done. Make sure it specifically states that it is OSX compatible, many are not. You want one which has driver built in OSX - this one https://www.amazon.com/dp/B007GFX0PY is suggested by hackintosh community, but I have no experience. I suspect simple google search will help you.
 

theapplehead

macrumors 6502
Dec 17, 2018
493
505
Chapel Hill, North Carolina
Hi
I just really found this site today, and I have a few questions.
I installed Os Mojave on this machine, and except for 3 programs everything seems to be working.
1.. the video card and greying of the side bars and menu
2. No support for BT

has a patch or driver been written for the BT? I've searched the net but found nothing.
I'm not concered about the video card..
I can not update to 10.14.x not buy the system update or installing from a .dmg.
I could use any assistance.
Best
Dave
There is a workaround for the grey menu bars via a GitHub patch. But you should be familiar with using terminal and realize that you run the risk of potentially locking up your computer. You will need to patch the CoreUI and and HIToolbox. Here is the link. Good luck!
https://github.com/SpiraMira/HybridMode-Public
 

Sanddoc

macrumors newbie
Original poster
Mar 12, 2019
15
0
You may be able to find some suggestions how to patch the driver to be usable for your old BT or copy driver from older OSX. Not sure.

If that does not work, buy BT dongle which is Mojave compatible (they are cheap $7 - $20) and plug that into USB port and you are done. Make sure it specifically states that it is OSX compatible, many are not. You want one which has driver built in OSX - this one https://www.amazon.com/dp/B007GFX0PY is suggested by hackintosh community, but I have no experience. I suspect simple google search will help you.
Thank you for the reply
I did buy the IOgear 4.0 GBU 521... IO gear states that it does not support Os Mojave...
I don't know how anyone is using it. But on a mac that dongle does not have support.
I would not even know how to look for the driver from High Sierra to install in Os Mojave if
it is even possible.. Apple is getting real BS.. that is a simple driver to install for them, they just
wanted to cut the older MBP out...
I could also buy a airport\BT card and install it.. which was installed in the 2012 MBP
in fact I did buy one off ebay, but the seller lied and sent me another chip instead not supported
by Mojave.... I'm sending it back... BS
the correct chip ends in CAX... and since 2012 MBP is supported by Mojave I think that chip
would work in my 2011... I just thought others might have come up with the driver patch, since
so much work seemed to be done... and that is such a small item...
oh well...
Best