BTstack mouse

Discussion in 'iPad Hacks' started by hecticsix, Jul 19, 2011.

  1. hecticsix macrumors member

    Joined:
    Jun 17, 2009
    #1
    Hi,

    anyone using BT stack mouse with the current jailbreak on Ipad 2 4.3.3 ?

    also, how well does the Apple wireless keyboard and Apple magic mice work together ?

    thanks ! :)
     
  2. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #2
    I have it installed but no mouse to use with it. I am also curious if anyone knows it absolutely works on iPad 2.

    Really wish the hack that enables a cursor for a Bluetooth mouse would also support a USB mouse via the cck.
     
  3. trsblader macrumors 6502

    Joined:
    May 20, 2011
    #3
    Just tried BTstack mouse with the magic mouse I got with my 2011 iMac, and it connects just fine. Ipad 2 16gb wifi only on 4.3.3. I haven't used it a lot, nor used any other versions on other devices, but this doesn't work with cydia at all, you still have to tap the ipad to do anything. Haven't tested anything else.
     
  4. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #4
    Thanks for your input. I am surprised that the cursor doesnt appear using Cydia. Does it dissapear from screen or does the mouse buttons stop working?

    If you wouldn't mind could you please test it in various applications like safari, pages (if you have it), and so on? I have been hesitant to buy a magic mouse without absolute certainty that the mouse cursor works in the apps I would have a use for it in (like pages and LogMeIn/Splashtop).
     
  5. trsblader macrumors 6502

    Joined:
    May 20, 2011
    #5
    The cursor is there, it just doesn't physically work. If you click on any buttons, links, menu bars, sources, etc, it doesn't do anything in cydia.

    Other things I've found:
    If you click disconnect in the actual bt mouse application it doesn't work with the mouse, you have to manually click.

    It does work with sbsettings and my background app.

    Upon further investigating, it doesn't work for any apps. It will launch the app from the springboard, works with folders, etc. Once the apps launch, it is useless, even in safari or mail.

    At this point, I cannot suggest using it as hardly anything works correctly.
     
  6. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #6
    Wow, thanks for your testing. Saved me from spending 70$ for no reason right now. Hopefully the application just needs to be updated to work on iPad 2 4.3.3
     
  7. trsblader macrumors 6502

    Joined:
    May 20, 2011
    #7
    No problem, glad I was able to help save some time and money. I do hope they update the app for everyone in the future
     
  8. waltermitty macrumors member

    Joined:
    Apr 25, 2010
    #8
    Cydia does not load unnecessary modules because it is able to modify them... SB settings is not loaded either, for instance.
     
  9. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #9
    I believe what he was saying is that btstack mouse stops working properly whenever you launch any app. On the iPad 2 running 4.3.3, btstack mouse is apparently not fully functional the way it is in all the demo videos on the iPad 1. I can't find a single video of btstack mouse working on an iPad 2. I would love to be proven wrong though because I really want to use a mouse for Pages.
     
  10. ZZ Bottom, Jul 22, 2011
    Last edited: Jul 22, 2011

    ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #10
    Just found a thread where the developer stated that he has fixed the problem, from less than a day ago: thread

    There are a couple users that have confirmed the btstack mouse app is working correctly now in 4.3.3. Looks like I'll be buying a magic mouse after all.
     
  11. mrlowkey macrumors member

    Joined:
    Apr 10, 2011
    Location:
    singapore
    #11
    Yup...MouseSupport svn.r201-8 update solved the problem for me..ipad & magic mouse works very well
     
  12. hecticsix thread starter macrumors member

    Joined:
    Jun 17, 2009
    #12
    thanks for the testing and replies everyone! :)

    i have one last question, i seen the use of magic mouse on ipad in youtube, but it seems that the scrolling is not like how you would use it on a PC.

    it requires holding and moving the mouse (similar to how we use our fingers on the ipad) instead of scrolling using the scroller

    is this still the case with this update ? thanks
     
  13. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #13
    Is this the BTstack Mouse v 1.0-25562 in cydia?
     
  14. ZZ Bottom macrumors 6502a

    Joined:
    Apr 14, 2010
    #14
    Just search for "btstack mouse" on cydia. It should install the recent patch with it. If you want to be certain just reopen cydia after btstack mouse installs and check under the changes section for any mouse related updates.
     
  15. reyno28 macrumors member

    reyno28

    Joined:
    Jun 17, 2010
    #15
    tried to install btstack mouse today and it gives me an error stating it can't find the package.

    nevermind. I closed out of cydia and was able to install after that.
     
  16. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #16
    Thank u
     

Share This Page