Buffalo 54g won't work with my TiBook!

Discussion in 'PowerPC Macs' started by SimonMakus, Nov 21, 2007.

  1. SimonMakus macrumors newbie

    Nov 21, 2007
    Hey everyone, first post, and I'm having a little problem. Two weeks ago I ordered a Buffalo 54g card from Wegener Media.

    I received the card only forty eight hours after but when I popped it into the cardbus slot, it didn't work.

    No vendor ID in the dropdown menu in the top right of the menu bar. No en1 interface anywhere. No airport in internet connect. Nothing. System Profiler says pci14e4,4320 in the PC Card section, and something else in the PCI section.

    Yes, the cardbus slot works fine and is properly secured and other cards work ok in it. I'm at a loss here guys.

    I sent the card back thinking it was a hardware problem with it. I just got the card back today, after shipping it back to Wegener Last Wednesday night. Apparently the RMA guy went on vacation. Nice eh? Anyway, the guy says he tested the card in two other TiBooks and the card is fine. I'm going to agree with him now and say it's a software issue now.

    I've done 2 clean tiger installs and countless pram, pmu, nvram, all, resets. Oh, permissions repair too. Everything I could think of that you would normally do while troubleshooting. Nothing has worked, so now I'm going to clean install 10.3 and see if I can get closer somehow that way. Wow, what an insanely long post. Sorry about that!

    Any ideas?
  2. SimonMakus thread starter macrumors newbie

    Nov 21, 2007

    So I did a clean Panther install... still no luck. What am I missing here? None of my OS installs have been full installs, so I might try that next.
    Nobody has any thoughts??

Share This Page