Bug in Mac Mail?: using multiple SMTP servers

Discussion in 'macOS' started by alexandrito, Sep 11, 2010.

  1. alexandrito macrumors newbie

    Joined:
    Sep 11, 2010
    #1
    I use mac mail for my mac account and exchange. In preferences for smtp server I have set "only use this server" for each account, ie mac account sent emails end up in mac sent mail box and exchange sent emails end up in exchange sent items box.

    The problem now is that despite the fact that I select an account to send a mail, lets say my exchange account, Mail does not send the mail and return a dialog box where I have to select the exchange smtp server manually. This also happens when I send a mac mail, then I have to choose the mac smtp server to send the mail out.

    This is highly annoying because your work gets interrupted by this popping up "cannot send mail using the server Mac" messages! Only after selecting the server the message is sent. If I uncheck 'only use this server' then all mails are sent but with the mac server! So my exchange sent items box remains empty.

    My conclusion is that the 'always use this server' option just does not work.
    Mail does not remember what server to use and asks the user for every single mail.

    Does anyone have a solution for this or is it really a bug?

    Thanks Alex
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    You have not given nearly enough information to solve your "problem." Some things that you need to understand:
    1. You cannot use just any SMTP server on just any domain.
    2. Many Exchange servers are restricted to one domain except for the Outlook Web Access web client.
    3. An SMTP server is just a relay. It is a security measure for email providers to restrict SPAMMERs and other undesirables from spoofing their domain names and other nefarious acts.
    MacOS X 10.0 acted as its own SMTP server and did not require one from an email provider to perform the function. There is nothing that SMTP does that the user should care about. There is no reason for you to care which SMTP server handles your outgoing messages.

    What are you trying to accomplish?
     
  3. alexandrito thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #3
    Hi thanks for your quick reply.

    So what I want to do:

    Use mac mail for 2 accounts: mobileme (@me.com) private emails and exchange server (web access) account at aps4rent (www.apps4rent.com)

    When I write a mail and I choose my mac email account, or I reply to a mac accout email, it should send the mail via the mac server and end up in the sent items box of that mail account.

    When I write a mail and I choose my exchange email account, or I reply to a exchange account email, it should send the mail via the exchange server and end up in the sent items box of that mail account.

    What happens: EVERY MAIL I SEND comes back, and a pop up screen says cannot send mail please select smtp server, then I have to click om mac.mail server when it is a mac account email and exchange smtp server if it is an exchange account email.

    In other words, for every mail I send I have to choose which send server to use. This is very cumbersome.

    In prefereces I had ticked 'only use this server' with each account and et the appropriate server. Unfortunately it does not work in practice and mail 'loses ' which server should be used, while this should be automatic.

    Now how can I put settings that I dont get this dialog box with every mail I send...

    Thanks Again Alex
     
  4. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    That's all good and fine, but the information that you are not giving is the most important. You don't say which domain provides your connection to the Internet. It makes a difference. You can expect different issues when you roam Wi-Fi hotspots than when you connect through your Wi-Fi network at school.

    I have had some success using authenticated SMTP Port 587 rather than unauthenticated SMTP Port 25. In my previous post, I told you that a SMTP server is just a relay. It makes no difference to you which SMTP handles your outgoing messages as long as they are sent. You may setup almost any email accounts with whichever SMTP server that will send your messages. The iPhone is wonderful in this regard in that it will test each SMTP server you have setup until it finds one that works. The MacOS X 10.6 version of Mail makes it easy to manually select your SMTP server.

    If you want to send email from roaming Wi-Fi connections, then you need to learn some of the intricacies of email. Each domain and each email provider can be expected to have details of its setup that are unique. You need to learn enough about the universe of such details to know what to try to get your messages through. There is no magic bullet. It is trial and error.
     
  5. alexandrito thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #5
    Issue is Not SMTP but Mail itself

    Thanks for your explanation. The issue here however is not SMPT, because when I mail with mac account and manually select mac smtp server the mail goes out with no problem, equally when I send the message with exchange account selected and I manually select the exchange smpt server.

    The issue is that MAIL SHOULD SELECT THE OUTGOING SERVER AUTOMATICALLY AND NOT ASK ME FOR EVERY MAIL SENT!

    So it is the handling of multiple mail accounts in Mail that does not work automatically for sent mail. I checked 'only use this server' with each account so I should not need to click on the right SMTP server with each mail send. EG when I send a mail with my mac email address, Mail returns a dialog box to choose which smtp server. If I select mac SMTP is goes without problem. If I choose Exchange SMTP server it does not and returns the dialog box until I choose Mac SMTP. Same for Exhange, if I send a mail from Exhange address in Mail it only goes out after I select the Exhange SMPT server. If I change the mail address in the message then ofcourse it can be sent with the other server.

    So if mail would use automatically Mac SMPT for mac mails and Exhange SMTP server for exchange mails the problem would not exist! The settings are right but Mail does not do it so it must be a bug I guess..

    Regards Alex
     
  6. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #6
    I'd have to guess that this is a problem with Mail's interface to Exchange. I've got multiple accounts with three different POP/SMTP mail providers and replies always go out to the correct SMTP server. New messages go out to the same server of the selected Inbox. It will only goof up if I don't select an Inbox and create a new message, then I guess it uses the last SMTP server used.
     
  7. alexandrito thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #7
    Bug Mail

    thanks guys I guess it will be a bug in Mail then,
    strange that not more has been written about it...
     
  8. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #8
    You have give absolutely no evidence that there is a bug in Mail. For my part, I have done the best of ability tried to explain these issues to you. Unfortunately, they seem to be beyond your ability to understand. The reason that nothing more had been written is the there was nothing more to say.
     
  9. alexandrito thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #9
    Ok this is all well but the problem is not solved.

    Let me put it in a different wording:

    How do I stop mail from asking me with every mail I want to send which SMTP server to use, taking into account that I ALREADY selected the option in preferences that the SMTP server of the sending account should be used (and so Mail should know which server to use and not ask for it everytime)?

    Thanks
     
  10. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #10
    If you look at the account information, is the "Use only this server" box checked for each account?
     
  11. garytravel macrumors newbie

    Joined:
    Feb 2, 2011
    Location:
    OREGON
    #11
    this is what i think he is meaning

    Outbound SMTP server
    I'm having the same trouble. The inbound server, and the OWA server set up nicely. But as I set up the Outgoing SMTP server for my Exchange account, it seems to hang while looking for it (mine is the same server for all 3). It doesn't even seem to get to the user/password authentication.

    Using another SMTP server to send messages works, but then it's tagged with that email address, and not the Exchange one.

    so agin, i want to send email that has the exchange address sent and reply, when i pick the exchange account, but it make me switch to the POP gmail account in order to send, and that cause people to think i want them to reply to the gmail.

    If anyone finds a solution, post it please.
     
  12. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #12
    We know that you have an Exchange account. We also know that you are having SMTP server issues. However, we know absolutely nothing else. The information that you are leaving out is extremely important.
    1. Which email client?
    2. Which version of Exchange Server?
    3. Is the Exchange Server limited to its own LAN or is it open to the public.
    4. Outlook Web Access is a webmail interface to your Exchange Server. What does that have to do with anything?
    5. Are able to receive messages on your Exchange account in locations where you cannot send it?

    On other fronts, I posted that there is no real connection between your POP3 server and your SMTP server. You may setup an account in your email client with POP3 and SMTP servers on two completely unrelated domains.
     
  13. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #13
    I don't know if this will help but...

    I use my own domain to send and receive email. For a while I used a dns registrar that somehow got themselves associated with spammers. My domain got picked up as blacklisted whenever my mail touched their servers. I changed to another provider. I took the added step of paying for email service and using their IMAP and SMTP server. For a while, I used gmail and mobile me. I learned something interesting. Mobile me would not let me "spoof" and say that mail I was sending was from my domain. It did not matter that I had it set to log in so I could send mail. Gmail, otoh was content to send mail as any domain I had set up in my gmail preferences as one of my accounts for it to "send mail as". I complained to Apple about this and they called it "an advanced feature" they never intend to support. Yeah, right. Nobody is ever gonna go out and register a domain and want to use mobile me for their email. Sheesh.

    Back to your problem. Do you have it set to log in to send mail? I have found this gets around a lot of problems. If you log in, servers (except mobile me) tend to be more forgiving of where you claim your email is "from". Of course spammers could use this to send out emails with bogus return addresses but since they logged in to send them, it should be possible to track them down and close their accounts so I don't understand why more Apple insists on only allowing you to send email with the from address you used to log in. For instance, I can aggregate email accounts from 3 colleges I have attended, work and home to one inbox. I should be able to at reply as whoever the email was addressed to. Gmail: fine. MobileMe: Not fine. So it turns out I have my domain/email provider set as the "use only this server" entry for all my email, even my mobile me email because there are times I'm replying from my Mobile Me inbox to an email that was forwarded there from another account and I don't want Apple popping up some nuisance dialog asking me which SMTP server to use this time. Find one that is flexible about who you list as your "from" address (I know gmail is flexible as long as you have each of your identities set up in your gmail account settings), set it as the "only use this smtp server" for all your email accounts and you should never see that annoying "duh which server should I use?" dialog again.
     

Share This Page