Resolved [bug?]iTunes 10.5 b5 or iOS5 b5, keep restore

Discussion in 'iPhone' started by jnozsc, Aug 7, 2011.

  1. jnozsc, Aug 7, 2011
    Last edited: Aug 8, 2011

    jnozsc macrumors newbie

    Joined:
    Feb 26, 2011
    #1
    I updated my iPhone 3GS and iPad2 to iOS5 yesterday via OTA.
    And I updated iTunes to 10.5 b5.

    Everything looks like fine, except one thing:

    (1)syncing with iPhone & iPad2 works fine

    (2)if I relaunch the iTunes, the iPhone cannot sync, iTunes brings me to the "set up your iPhone" screen
    (2.1)if I choose the "restore from my old backup", iPhone will reboot, and then still the "set up your iPhone" screen. I keep trying it, keep restore, no more change.
    (2.2)if i choose "set as a new iPhone",iTunes will sync with my iPhone, to my surprise, all my apps' documents are still available after sync as a new iPhone.

    Now I cannot close my iTunes, if I chose it and relaunch it, this bug will replay, I hope the next beta version of iTunes can fix this.

    Anyone has the same issue? or anyone knows how to fix it?

    ***** update *********

    restore from the ipsw file can solve this issue. thanks for replying
     
  2. SanjeevRana macrumors 6502a

    SanjeevRana

    Joined:
    Aug 2, 2011
    #2
    No such issue here ... maybe a stupid question but did you restart the system after upgrading iTunes ... ? I know many people skip this
     
  3. jnozsc, Aug 7, 2011
    Last edited: Aug 7, 2011

    jnozsc thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #3
    I have restarted my MacBook pro and iPhone for a few of times.
    And I have fixed the disk permission by Disk utility.
    It doesn't fix this bug
     
  4. briansanderson macrumors member

    Joined:
    Sep 16, 2003
    #4
    I have this same problem with iOS 5 beta 5 and iTunes 5 beta 5. This is highly annoying. Not surprised though this is beta software.
     
  5. macingman macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #5
    This is understandable. If you read the release notes you will see Apple says to make sure you have a backup of everything in a non-beta form before using the beta.
     
  6. jnozsc thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #6
    thanks for confirming that. I will be waiting for the next release to fix it
     
  7. flightsimmer, Aug 7, 2011
    Last edited: Aug 7, 2011

    flightsimmer macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    O'Fallon, IL
    #7
    I was getting the same exact issue, and it really frustrated me last night. I eventually hit setup as new, just so I could sync a few new items to my phone. What a pain that was..... All of the sites I've read stated "You won't lose anything when you do this". Technically, you don't. Until you try to sync your apps / music / ringtones. iTunes automatically thinks since you setup your device as a new phone, so you don't want any of your apps or music on there anymore. Resyncing 98 applications, multiple ringtones, and music by hand isn't the most pleasant thing to do when you're already aggravated.

    Luckily, I was able to get everything back to where I wanted it, but iTunes has decided to go bonkers once again. I'm going to see if going back to iTunes 10.5b4 changes anything and I'll report my findings.

    *After iTunes 10.5b4 install*

    No luck. Looks to be an issue with iOS 5 beta 5.

    By chance, if you're having issues, did you do the OTA update without restoring? I'm thinking that's what might be causing the issues.
     
  8. jnozsc, Aug 7, 2011
    Last edited: Aug 8, 2011

    jnozsc thread starter macrumors newbie

    Joined:
    Feb 26, 2011
    #8
    what do you mean “do the OTA update without restoring”.

    (1)iOS5 b4 -> erase all content and reboot -> setup iPhone as a new iPhone ->OTA ->iOS5 b5 -> restore from iTunes.
    (2)iOS5 b4 -> erase all content and reboot -> restore from iTunes -> OTA ->iOS5 b5

    i guess you mean the first one, do you?

    yes I use the first one, because the second doesn't work, I cannot get the OTA to b5 after restoring from iTunes.

    I think maybe you got the point, I will try to restore from the b5 ipsw file.

    wait for my update :)

    *******after the restore************

    it works!
     
  9. flightsimmer, Aug 7, 2011
    Last edited: Aug 7, 2011

    flightsimmer macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    O'Fallon, IL
    #9
    Yeah.... I meant "perform the OTA update without erasing the contents and settings, then restore from iTunes". I went ahead and did another round of "Setup as new", set back up all of my apps and ringtones, made sure everything was 100% the way I want it, and backed up the data. I just restored my phone using the .ipsw file, and I'm waiting for everything to copy back over.

    Let's hope that fixes it.....

    **After the restore**

    Well, looks like a full backup / restore with the ipsw fixed the issue. I've quit iTunes and rebooted my iPhone multiple times, and all seems to be well. That's what I get for trying to cut corners....
     
  10. jeehtoven macrumors newbie

    Joined:
    Jun 3, 2011
    #10
    Solution

    Here's what worked for me:

    1. Begin to restore the phone.
    2. When the phone says "Restore in Progress," unplug the USB cable from the computer, in order to interrupt the restore.
    3. You will see a button on the iPhone that says "Restart". Press restart.
    4. Once the phone restarts, it will attempt to sync the phone, bypassing the restoration screen. Go to the "Summary" tab and deselect the Wi-Fi sync option.
    5. Press apply to re-sync. It will do a general sync, depending on if you've restored the phone previously. You may need to check if you want apps, music, and the such restored by you.
    6. Try to add an mp3 to verify that the restore works.

    There is a bug with the Wi-Fi sync that causes this problem. I'm pretty sure the next beta or final release will fix this, but I wouldn't do Wi-Fi syncing for now. My theory is it has to do with when you connect to different wireless environments, and it can't detect the one that you normally sync too. That's my opinion, though.
     
  11. oz81dog macrumors newbie

    Joined:
    Aug 22, 2011
    #11
    That worked for me, thanks.
     

Share This Page