Bug with rules in Apple Mail

Discussion in 'macOS' started by scotty321, Nov 15, 2010.

  1. scotty321, Nov 15, 2010
    Last edited: Nov 15, 2010

    scotty321 macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #1
    There is a bug when it comes to rules in Mail in 10.6.4 and 10.6.5 (and possibly earlier versions of Mail as well).

    Here are the steps to reproduce the bug:

    1. Make sure you have an IMAP account in Mail.

    2. In your IMAP account's Mailbox Behaviors, UNCHECK the box that says "Store draft messages on server". This ensures that your draft messages will be saved locally on your Mac instead of on your IMAP server.

    3. Create one new rule that would ALWAYS be true of ANY new message that you would be creating in mail, such as:
    "From contains (your email address)"
    OR
    "Sender is a member of group (name of a group that your own card is a part of)"
    Don't create both of those rules... just choose one.

    4. The action that the rule should perform is:
    "Set Color of text (choose a color)"
    Make sure that you're NOT setting a BACKGROUND color, but rather that you're setting a TEXT color.

    5. Save the rule.

    6. Now, create a new message and start typing.

    7. Save the message as a draft once.

    8. Notice that the message shows up in your Drafts folder with the text color applied that you set in #4 above. This actually is a small bug right there, because rules shouldn't apply to messages in your drafts folder, but this first bug is not a big deal.

    9. Continue editing the message.

    10. Save the message as a draft for a 2nd time.

    11. This is where the major bug takes place. Look in your Drafts folder. Now, your message has shown up in the list of Drafts message with the BACKGROUND COLOR of the subject changed to the TEXT COLOR that you set in #4, which makes the message unreadable if you had chosen a dark text color. Even though you specified a TEXT color, Mail incorrectly applied a BACKGROUND color to the message. This is completely annoying if you're working on a bunch of drafts, because you can't even read the names of the drafts that you're working on without individually opening them up.
     
  2. scotty321 thread starter macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #2
    I have discovered a workaround to this bug.

    It turns out that the rule "Message Type Is Mail" DOESN'T trigger the bug, so I just added that as a criteria to my rule and now the problem doesn't happen!

    So now the criteria for my rule looks like this:

    -------
    If "ALL" the following conditions are met:
    "From contains (my email address)"
    "Message Type is Mail"
    -------

    That is the official workaround for this bug! :)
     
  3. doublespiral macrumors newbie

    Joined:
    Jan 21, 2014
    #3
    I don't know if anyone is still monitoring this thread. I have had this same issue for years. I had a workaround that I could use to get drafts to go back to a white background, but since "upgrading" to Mavericks, it no longer works.

    I used to be able to merely select all Drafts and then Apply Rules, and that would clear things up until the next time I saved a Draft. Annoying, but workable. Now that functionality is gone. I had posted about this issue on Apple Discussion board, but didn't get any helpful response: https://discussions.apple.com/thread/1593374

    Scotty, can you tell me what the "Message Type is Mail" has become in more recent versions of Mail? I don't have that option in my version.

    Thanks,

    Erik
     
  4. scotty321 thread starter macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #4
    I don't use Mavericks, but the workaround that I use in Mountain Lion is using the Mail Act-On plug-in. It lets you assign a keyboard shortcut to any rule, so I have a rule that changes the background color of ANY MESSAGE to white. So I just highlight the message in my Drafts folder, and use the keyboard shortcut to eliminate the background color. I use Mail Act-On for a whole bunch of other cool things, too… not just working around that one bug. That company makes several great Mail plug-ins, in fact.
     

Share This Page