Bugs in IOS 4?

Discussion in 'iPhone' started by jdylan, Jun 23, 2010.

  1. jdylan macrumors regular

    jdylan

    Joined:
    Dec 31, 2006
    Location:
    Bagram, Afghanistan
    #1
    I've found a major one, kind of surprised it wasn't caught earlier. Maybe I'm the only one though. After I watch a movie and left-swipe and the "delete" button comes up, I press it to delete it, but it crashes and goes back to the home screen. When I reopen "ipod", the movie is still in the playlist, but now I can't open it anymore (if I wanted to).

    The second issue I have is the incredible battery drain! My iPhone is 9 months old and I used it regularly, even watching movies at the gym while on the bike, and it would last all day, but today I watched one 50 minute film and the battery was 75% dead! And yes, I have wifi off, brightness down, all the usual tricks. I can't figure out what is draining it so much!:confused:
     
  2. gforce216 macrumors 6502a

    Joined:
    Jun 17, 2009
    #2
    I found one that I don't know whether it's an app fix or an OS fix. When you open up Pandora or Slacker and leave the app, then pause your music, you're unable to change your ringer volume. Instead it changes the app's volume. With the iPod app once you pause it the ringer volume is able to be toggled. Weird bug.
     
  3. willysid macrumors newbie

    Joined:
    Apr 9, 2008
    #3
    Podcast Error

    I'm finding when I play a podcast, playback position is not remembered, and it does not show an advance of time on the slider or allow moving forward or back within a podcast. An Audible audiobook works fine.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Battery drain is due to the always on wifi in ios4.

    The only one I've found is if you reply on macrumors and whilst typing hit return the txt goes twice as big!
     
  5. willysid macrumors newbie

    Joined:
    Apr 9, 2008
    #5
    My podcast problem proved to be isolated to one or two episodes in one podcast. Rebooting, deleting and replacing problem episodes corrected. Scrubbing etc. works now.
     
  6. FrogTastic macrumors regular

    FrogTastic

    Joined:
    Nov 20, 2008
    Location:
    United Kingdom
    #6
    iOS4 is the biggest piece of crap to come out from Apple to date.

    Loses carrier settings, even after updating them 100 times. Drops calls, super slow. Bad signal.:mad:

    Lets face it, task suspension is a joke. Apps arent suspended, as they need to be reloaded when u go back into it.:mad:

    What a joke!
     
  7. army91c macrumors 6502a

    Joined:
    Mar 9, 2009
    #7
    What are you talking about? I have no issue with carrier settings. Haven't dropped a call, super fast, no bad signal :D
    When I go into the "joke of suspended apps" they don't re-load, except for facebook that has to re-load anyway because there is new information on the page. Sorry you're having issues and glad I'm not.
     
  8. FrogTastic macrumors regular

    FrogTastic

    Joined:
    Nov 20, 2008
    Location:
    United Kingdom
    #8
    Every app reloads. Nothing is "frozen", until you go back into it.
     
  9. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #9
    I've noticed I'm having major problems with my blueant Q1 headset after upgrading to 4.0

    It never stays connected anymore and I always used to be able to hear the phone system sounds like, locking/unlocking, dialing numbers, text and email notifications.

    Has anyone else experienced any similar problems?? Or have any suggestions...I've already tried "forgetting" the device and repairing it with the phone.
     
  10. drjdan macrumors newbie

    Joined:
    Jan 27, 2008
    Location:
    Dallas TX
    #10
    My Blue Ant Q1 disconnects and reconnects all the time on iPhone 4 when I try to use it. I oul use it when I want to listen to some audio feed. I did not use in on old 3GS after upgrade to iOS4.

    I also have a Motorola flip that I use during the week and does not have the problem.
     
  11. JeffreyDJ macrumors regular

    Joined:
    Jun 26, 2010
    #11
    I have had a few:

    1. Deleting an image from your photo gallery leaves a black square where the image was. This is a minor thing, and the block square disappears if you make the screen refresh (i.e. leaving the app and going back, or clicking back to the list of albums and clicking in again).

    2. The wireless signal seems to "freeze". Going in and renewing the IP has worked everytime but once; I had to restart that time. My old iPhone doesn't have this issue, nor does my wifes.

    3. I've had a few instances where the Google Maps wouldn't update, but everything else was fine on a 3G (e.g. safari, email, etc.). This could have simply been Google's Map service and not a bug.

    That's all I have so far (outside of the 3G/Wireless G signal drops when held, but it's overkill to report that again).
     
  12. powaking macrumors 6502

    powaking

    Joined:
    Jul 3, 2008
    #12
    One time I went into the Photo app and was put in the Album page. Thing is there were no albums listed and I couldn't back out. Had to reboot the phone to get that cleared. Also noticed that ipod controls outside of the ipod app doesn't change the play/pause icon.
     
  13. B2fl3 macrumors newbie

    Joined:
    Jun 25, 2010
    Location:
    Rochester Hills, MI
    #13
    I'm pretty sure this is a bug but I sometimes can't use 3G even though it shows all bars I have to turn it off and use edge or wifi.
     
  14. djjeffroe macrumors newbie

    Joined:
    Jun 25, 2010
    #14
    I don't have a Blueant, but my Jawbone Icon is doing that same thing. It worked perfect on 3.1
     
  15. PoitNarf macrumors 65816

    PoitNarf

    Joined:
    May 28, 2007
    Location:
    Northern NJ
  16. IMaMACnow macrumors newbie

    Joined:
    Jun 1, 2009
    #16
    Bugs on a previously jail broken 3G

    Ok- while my iPhone is not jail broken now... Nor was it when i upgraded id figure id start with that proclamation When I upgraded to ios4 I have some crazy performance issues. Overall it's a slower experience for App loading and closing. The battery display doesn't change when I charge, which has lead me to bring my AC adapter to work for some extra juice.. a simple reboot proved my charge was 100%. When I changed the lock screen picture (3G can't change backround) ever so brief buttons appear "set wallpaper" "home screen" "both".
     
  17. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #17
    Nowhere near the piece of crap 2.0 was when it first came out.
    You would need to restore your phone 2-3 times a day thru itunes.
    Its really not bad since I used all 4 versions of Iphone OS's released its the most well "baked" new iphone OS they have put out IMO.
     

Share This Page