Building an App against nightly Webkit no longer loads webplugins

Discussion in 'Mac Programming' started by hurrikenux, Jun 7, 2007.

  1. hurrikenux macrumors member

    Joined:
    Jun 7, 2007
    #1
    This is very perplexing (to me at least). I've been compiling a Webkit-Based browser against the nightly WebKit and everything seems to work fine. However, there is a fatal error when trying to load any webplugins (Quicktime, Flip4Mac, etc). My workaround has been to load disabling them into the code and use the Carbon-based ones (.plugin).

    Anyone worked with the Webkit nightly for this? I have found a few instances of this error floating around the web, but with no solutions.

    I can post a crash log if anyone would like.
     
  2. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #2
    I would suggest stopping by the webkit irc channel and asking there; I've found them to be extremely helpful, although you may have to try a few times if you're unlucky enough to join when none of the regulars are active. If it is indeed a bug with webkit trunk, the next step would be filing a report at bugs.webkit.org.
     
  3. hurrikenux thread starter macrumors member

    Joined:
    Jun 7, 2007
    #3
    I'll check them out on IRC; its funny, I used to be on IRC all the time. I don't think its a WebKit bug, I think the error lies with how the build is being configured. Perhaps there is a variable to enable loading of plugins directly, instead of how it may be loaded using the export_dyld method. I believe it is I who is missing something.
     

Share This Page