building from sourcefiles fails..

Discussion in 'Mac Programming' started by E1000, Jul 14, 2011.

  1. E1000 macrumors newbie

    Joined:
    Jul 14, 2011
    #1
    Hi all,

    After 2 days of trying, I'm desperate for some help.. I'm trying to build an executable from Xwisp2 source posted here (the link source files is on the bottom.). Xwisp2 is a program to communicate with a PIC programmer (Wisp628) via the serial port and upload data to a microcontroller or do some other stuff. It says that Mac users have to compile from the source.
    The first thing I tried was "make -f xwisp2_gu.mak" in Terminal. This gave the following errors:
    Code:
    xwisp2_gu.mak:14: *** missing separator.  Stop.
    and
    Code:
    xwisp2_gu.mak:14: xwisp2.ver: No such file or directory
    After some digging in to the code I (falsely?) concluded that xwisp2.ver was missing and I added a file named xwisp2.ver containing:
    Code:
    VMAJOR = 2
    VMINOR = 0
    VSUFFIX = 0
    and I changed line 14 in xwisp2_gu.mak into:
    Code:
    include xwisp2.ver
    instead of
    Code:
    !include xwisp2.ver
    So far so good. I got rid of the errors in the make file, but now the real trouble started. The header file "share.h" was missing. I'm not sure if this file used to be in OS X, or never was, or should be, because I've only been working with OS X for a short period now. It appears that the share.h header has to do with the sopen function (check here). The sopen function is used in xwisp2os.c. I found a version of share.h by downloading Open Watcom. But I found out that the header files in Open Watcom are somewhat different from the ones in OS X (in usr/include).
    And this is where I got lost. I have now clue how to add share.h to the files in such a way that it is accepted. I have tried replacing all the header files with the Open Watcom headers but that didn't work..
    Does anyone have any experience with share.h or knows how to compile this project?

    Thanks in advance,
    Emiel
     
  2. Madd the Sane macrumors 6502a

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Is there a configure script, or an autogen.sh file?
     

Share This Page