iOS building speex library on iPhone

techgentsia

macrumors newbie
Original poster
Jul 19, 2011
9
0
I am trying to build speex library for iphone. I edited the makefile from i386 to ARM but on configuring it automatically changes back to i386. Also i tried to change the host and build in commandline(make --host=arm-apple-darwin10 --build=arm-apple-darwin10). But it says "This program built for i386-apple-darwin10.0". Where should i change to compile for ARM or should i need to write a new makefile for ARM. I am new to makefiles and iOS. Please someone help me to solve this out.
Thanks in advance.
 

techgentsia

macrumors newbie
Original poster
Jul 19, 2011
9
0
Solved myself :) .Started an iOS static library project and builded the source code(src, libspeex). Link the header search path to speex.h(/include/speex/speex.h) in project target. Done. Hope this helps someone.
 
Comment

Dreyk

macrumors newbie
Sep 2, 2011
1
0
How?

Can you explain me how to compile the library, and how to use?
I can't compile the library.
Please help me. And what src you downloaded?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.