Burning Crusade Install Won't Detect WoW

Discussion in 'Mac and PC Games' started by OblivionMage, Jan 27, 2008.

  1. OblivionMage macrumors newbie

    Joined:
    Jan 27, 2008
    #1
    I've recently bought the World of Warcraft battle chest, and World of Warcraft installed without a problem. However, when trying to install Burning Crusade the installer won't detect World of Warcraft. The message says:
    "World of Warcraft Required"
    "Please Install World of Warcraft before installing Burning Crusade"
    It then gives the options of buying world of warcraft online, viewing the readme, the manual and then customer support, and the last option is to just exit the installer.
    I can't figure out why it is doing this and I'd appreciate it if someone could help me out with this.

    ps: I'm on an iMac running os x.4 Tiger with an intel core 2 duo processor. My computer runs WoW perfectly so it isnt a matter of the system requirements. Also I installed WoW to the applications folder and I'm on an admin account, so not having administrator priveledges isn't a big deal
    The burning crusade dvd is from the battlechest and I've tried to copy the installer onto my computer and running it from there but that didnt help either
    I've also tried downloading the trial bc from the WoW website (and considering my account is a full bc account then this would work as full bc) but that didn't work either, it wouldn't detect WoW on my computer

    I have emailed Blizzard and have gotten no response, as well as created a thread (also no response) on their MAC Support forums.
    Any help would be appreciated, I have reinstalled many times and have tried installing to different directories (other then applications) with the same results.

    Cheers,
     
  2. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #2
    World Of Battlecraft Battle Chest is not the same as the Muli-Player Online Version but for Single Player Only. Therefore Burning Crusade will not work. You need to buy the other version that is for Online Playing Only.

    Bill.....:apple:
     
  3. OblivionMage thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #3
    Sorry but the World of Warcraft battlechest is for online play..there is no such thing as legal single player World of Warcraft. I have no clue where you got this idea from..
    Incase I was unclear, I can play World of Warcraft (not BC) fine. Just when I use the BC install disc (Or download the one from thier site) it will not detect that I have World of Warcraft (original) installed.

    My account has also been upgraded to a Burning Crusade account (How I got the download).
     
  4. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #4
    I can assume then that you have the latest (pre-TBC) patches installed. Have you tried downloaded the regular WoW client from the Blizzard website as well, then immediately updating to TBC using the downloaded version? Only thing I can think is that the version that came with the Battle Chest is somehow wonky.

    Perhaps you can post what Mac and version of OS X you're using, too.
     
  5. OblivionMage thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #5
    It says this in my first post (10.4x). My computer also easily meets the reqs

    The game autopatches itself before you can play (WoW not BC)

    I could maybe download the normal WoW client off of thier site, but considering I can play it/patch it perfectly fine, I doubt that is the issue.

    Any other thoughts?
     
  6. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #6
    Whoops, yeah I just noticed that. Other than downloading both clients from the website I have absolutely no clue what to do, it's a very odd problem.

    Also, the game won't patch itself if you don't launch it after installing it. That's what I'd suggest... just install TBC immediately without even launching it.
     
  7. OblivionMage thread starter macrumors newbie

    Joined:
    Jan 27, 2008
    #7
    Hmm, that is a very good idea, installing without patching..I will try that.


    As for anything else, I can't think of any other possible things that can be causing this
     
  8. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #8
    Sorry, My Bad. Must have been tired. But thought you meant this version;http://pc.ign.com/objects/767/767553.html , which obviously not. But do remember that after restoring WOW after my Leopard upgrade it could not find the WOW executable even when I tried executing it directly from the WOW Folder in the Applications. Ended up renaming the WOW Directory so that I could copy over some of my stuff if I could get it working. Then reloaded and rebuilt it I believe as "apfhex" mentions and it corrected issues. Been a while but worth a shot. Surprised Blizzard has not responded they are pretty Mac savvy. Hope you get it fixed!

    Bill.......:apple:
     
  9. Chill macrumors newbie

    Joined:
    Jan 15, 2008
    #9
    Try the Mac Support forums at Worldofwarcraft.com, more blue posts than any other forum there.
     
  10. erinfudge macrumors newbie

    Joined:
    Jan 28, 2008
    #10
    Make sure you post during weekday business hours (8-8 PST). They don't staff the Tech Support forums outside that, and your post will fall too far back to be answered when they come in the next day.
     
  11. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #11
    I also agree with trying to download and not patch before you run the tbc installer. And the Mac specific forums over there are very nice. They actually have developers and stuff there talking to you.

    Only other thing I can suggest is to make sure you've upgraded your account and have the game installed some place the installer can see it/you have permissions set so you can write to it.
     
  12. fireyk macrumors newbie

    Joined:
    Sep 10, 2008
    #12
    same prob

    I HAVE THE EXACT SAME PROBLEM!!

    I have no idea how to fix it, please help me?
     
  13. ReanimationLP macrumors 68030

    ReanimationLP

    Joined:
    Jan 8, 2005
    Location:
    On the moon.
    #13
    Odd. It isnt the patches though, because I installed WoW on my PC using the download client option then patched and played my 10-day trial, then bought the full game, entered both keys on the website. Then when I went to log in, it said I required BC to be installed, so I installed it from the CD, logged in again and it all worked.

    I haven't ran WoW on any of my Macs, mainly because they all have such old graphics cards.
     
  14. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #14
    After some reading, the problem is caused from a corrupted preference file. To fix it do the following:

    - Click the Finder icon in the dock
    - From the Go menu, choose Go to Folder
    - Type in "~/Shared" and click Go
    - You should be able to see a folder named 'Blizzard' - move it to the Trash
    - Empty the Trash
    - Load up WoW (not the expansion) to the login screen
    - Exit WoW
    - Try the BC installer again - with a bit of luck it should find WoW this time and install correctly

    For reference, I found the information here
    http://forums.worldofwarcraft.com/thread.html?topicId=3121134471
     
  15. Bryanj026 macrumors regular

    Joined:
    Sep 22, 2008
    #15
    Solution

    the burning crusade is already installed on your computer. The updates you went through in the beginning installed the burning crusade on your computer. go to www.worldofwarcraft.com/account and click upgrade account and type in the product key and your good.
     
  16. KrazyLew macrumors newbie

    Joined:
    Jan 13, 2009
    #16

    I was experiencing the same problem and this completely worked. Thanks for the information. :)
     
  17. dbertsch macrumors newbie

    Joined:
    Oct 15, 2010
    #17
    Help Me please

    OK i have a problem i recently purchased WoW battle chest and the game never installed. now i got WoW installed after 3 days of fighting with it. i need Burning crusade installed but the installer dose not detect the game. and i searched for this shared folder...can't find it. HELP?
    :confused::confused::confused::confused::confused::confused::confused:


    Ive got the MBP 15.5 " same as bill.
     

Share This Page