Buying older Mac OS X versions and use on new iMac

kuroyume0161

macrumors newbie
Original poster
Nov 5, 2006
23
0
Just purchased a new iMac about a month ago. It came with Mac OS 10.6.2 on it. My software SDK and Xcode 3.2.3 will not work together very well. I keep getting the stupidest of (and so far unresovable) errors which didn't exist when on 10.4 or 10.5 using Xcode 2.4 or 3.1, respectively. In this economy, I cannot afford to be pulling out my hair with a new piece of software being readied for release (read: for sale) but unable to do the MacOS builds (Windows builds were done in less than an hour).

My questions are:

1. Where can I get official Apple Mac OS 10.4 (Panther) and 10.5 (Leopard) Full OS install discs? I am looking at eBay but there seems to be a wide variety of pricing and so on which is causing me confusion. I'm afraid (and cannot afford) to get burnt by purchasing something which will not work!

2. Will either of these work on the latest iMac (core duo 3.3GHz with 4GB)? Currently, I have 10.4 installed on an external drive which worked with my previous iMac (probably because it was installed from it) but it freezes on boot on the new iMac. Of course these older OSs would be installed onto two partitions on an external USB 1TB drive to preserve the 10.6 install internally.

Thanks,
Robert
 

Intell

macrumors P6
Jan 24, 2010
18,900
415
Inside
10.4 is Tiger.

It is not recommended to attempt to install an OS older then the one then comes on any Mac. Doing so will cause problems and many things may not work right or at all.

eBay is the only place to get those discs.
 

MisterMe

macrumors G4
Jul 17, 2002
10,678
47
USA
... In this economy, I cannot afford to be pulling out my hair with a new piece of software being readied for release (read: for sale) but unable to do the MacOS builds (Windows builds were done in less than an hour).

...
What are you talking about, Willis? Xcode is free. Xcode also includes SDKs for MacOS X 10.6, 10.5, and 10.4.
 

kuroyume0161

macrumors newbie
Original poster
Nov 5, 2006
23
0
He made make things in another SDK besides Xcode.
Yes, I am. And the api.lib and xcodeprojects for these are (were) made to work with the version of Xcode (and Mac OS) specified at the time. Unfortunately, as with all things Mac, backward compatibility is at the bottom of (or under) the list of features. I'm supposed to be writing for iPhone 4G, for example, and not 3G/3GS because, pfffft, nobody still has one of those (really?). Same with the application SDK that I'm using. There are people using three versions back which is over six years ago. I'm only supporting one version back which is nearly four years ago - and that is still causing me much grief! I'm so sorry, Mr. Jobs, I cannot always write software for the latest and only the latest version. :p
 

MisterMe

macrumors G4
Jul 17, 2002
10,678
47
USA
... I'm supposed to be writing for iPhone 4G, for example, and not 3G/3GS because, pfffft, nobody still has one of those (really?). ...
I am not sure what you mean. There is not now and never has been an "iPhone 4G." However, all iPhones, all iPod touches, and the iPad are supported by the current version of Xcode (iPhone OS 3.0 through iOS 4.0). As I said in my last post: "Xcode is free."
 

Intell

macrumors P6
Jan 24, 2010
18,900
415
Inside
I am not sure what you mean. There is not now and never has been an "iPhone 4G."
I hope you do know that there is now and forever will be an Apple iPhone 4G. The 4G is because it is the 4th generation of Apple's popular iPhone.
 

Intell

macrumors P6
Jan 24, 2010
18,900
415
Inside
It can be both. Apple calls the iPod Touch 2G the "Late 2008 iPod Touch" and the 3G the "Late 2009 iPod Touch"
 

kuroyume0161

macrumors newbie
Original poster
Nov 5, 2006
23
0
Okay, let's be mindlessly pedantic. iPhone 4 instead of 4G, but the point was made. :)

Yeah, Xcode is free but it is hard to control which frameworks are being used, especially if pointing to the 'system-specific' ones which are always the latest. One can install Xcode 2.x separately from an Xcode 3.x install but try installing 3.1 on a 3.2 system? Guess what happens? Xcode 3.1 OVERWRITES 3.2 because they don't easily allow you to install multiple versions of Xcode on the same system. Again, onward instead of compatible. Yep. It's free and you get what you pay for (where have I heard that before?).
 

GGJstudios

macrumors Westmere
May 16, 2008
44,436
800
I was proving a point. Nothing more.
I don't see any point proven. Apple doesn't refer to the iPhone 4 as the iPhone 4G, and neither does the general population. Just because you choose to mislabel it such doesn't make it factual.
 

Intell

macrumors P6
Jan 24, 2010
18,900
415
Inside
Apple doesn't refer to the iPhone 4 as the iPhone 4G, and neither does the general population. Just because you choose to mislabel it such doesn't make it factual.
Let me spin this for the iPod Touch: Apple doesn't refer to the iPod Touch Late 2008 as the iPod Touch 2G, and neither does the general population. Just because you choose to mislabel it such doesn't make it factual.

Yet whenever this is posted in MR you don't seem to go bananas.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,436
800
Let me spin this for the iPod Touch: Apple doesn't refer to the iPod Touch Late 2008 as the iPod Touch 2G, and neither does the general population. Just because you choose to mislabel it such doesn't make it factual.

Yet whenever this is posted in MR you don't seem to go bananas.
I'm not going bananas. I've also never seen those iPod Touch references on MR from anyone but you, in this thread.
 

MisterMe

macrumors G4
Jul 17, 2002
10,678
47
USA
Okay, let's be mindlessly pedantic. iPhone 4 instead of 4G, but the point was made. :)

Yeah, Xcode is free but it is hard to control which frameworks are being used, especially if pointing to the 'system-specific' ones which are always the latest. One can install Xcode 2.x separately from an Xcode 3.x install but try installing 3.1 on a 3.2 system? Guess what happens? Xcode 3.1 OVERWRITES 3.2 because they don't easily allow you to install multiple versions of Xcode on the same system. Again, onward instead of compatible. Yep. It's free and you get what you pay for (where have I heard that before?).
You don't need multiple installations of Xcode. As difficult as the concept is to grasp, Xcode includes the SDKs for multiple versions of MacOS X and iOS.
 

larkost

macrumors 6502a
Oct 13, 2007
534
1
To emphasize what MisterMe is saying: Assuming you choose to install the older SDK's while installing XCode (it is part of the custom installs), you can choose whatever SDK you would like to compile for/against.

To do so (using XCode 3.2.2):

1) Open your project

2) Click on your project in the "Groups & Files" pane (it should be the top item, and has a blue icon)

3) Select "Get Info" from the File menu

4) You should get a "Project Info" window for your project, go to the "General" tab

5) Change the entry in "Base SDK for All Configurations", and hit "Rebuild Code Sense Index" if you use that.

It is pretty non-sensical to think that Apple does not have a method of doing this. They have lots of teams internally who need to build things for older versions of MacOS X, and it is silly to think that they make their developers run older versions of their own OS to do so.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.