bye bye hard disk?

Discussion in 'iMac' started by lferlito, Apr 24, 2015.

  1. lferlito macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    iMac 24" early 2009 2.93 GhZ
    #1
    yesterday i tried to normaly boot my imac.
    everything was ok until the progress bar of yosemite stopped loading.

    i tried safe boot, single boot
    i tried to verify/repair my only disk using the recovery

    but the only aswer was: unable to unmount/deactivate the disk (italian translation lol)

    what can i do?
     
  2. MartinAppleGuy macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #2
    Try booting up and holding the 'alt' key when you hear the startup sound. If your hard drive is shown, use the arrow keys to select it (should already be selected) then hit enter. If it boots back into OS X, then its just unlinked itself from being the boot drive, so go to settings, and start up disk and select it there.

    Hope that solves it for you ;)
     
  3. lferlito thread starter macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    iMac 24" early 2009 2.93 GhZ
    #3
    Now, when i boot my iMac it goes directly to the recovery…
     
  4. MartinAppleGuy macrumors 68020

    MartinAppleGuy

    Joined:
    Sep 27, 2013
    #4
    Are you able to see the hard drive in recovery? Maybe it's corrupted and may need formatting. Do you have a backup of important data, or even better a time machine machine that you could restore from?

    If you can't see it though, it will sadly have to be a trip to the Apple Store to have the Hard Drive replaced I think. If you never wanted to, there is always the option of booting for external means.

    Hope this helps.
     
  5. lferlito thread starter macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    iMac 24" early 2009 2.93 GhZ
    #5
    i can see the hard drive from the recovery but every action i do (repair, format) just fail
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Sounds like that drive is a goner. :(
     
  7. Jmpdmh macrumors newbie

    Joined:
    Dec 29, 2013
    #7
    This happened to my wife's computer yesterday too. She has a 2013 iMac. She just updated her software yesterday. Did you update yesterday too? I took it to the Genius Bar, and they verified what I already knew. The drive is a goner. However, I also found this when searching for a solution. I was quoted 185 dollars at the Genius Bar to fix this. I bought an external and in the process of booing from an external. Here is the link.

    https://discussions.apple.com/thread/6995175
     
  8. lferlito thread starter macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    iMac 24" early 2009 2.93 GhZ
    #8
    Not exactly yesterday but, YES! I updated recently!
     
  9. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #9
    Something to consider:

    Just because you can't boot from a drive, doesn't mean the entire drive is bad or that the user data on it is lost.

    Your files may still be "there" -- even though you can't boot from the copy of the OS that's on the drive.

    You need a way to get "fully booted" to the finder from ANOTHER drive. Once you do this, it's possible the internal drive might just "show up", perhaps long enough to get your user files OFF OF the drive.

    This is why I ALWAYS advise others to keep a SECOND external bootable drive handy, preferably one that is "cloned" from the internal drive using either CarbonCopyCloner or SuperDuper.
     
  10. lferlito thread starter macrumors newbie

    Joined:
    Apr 24, 2015
    Location:
    iMac 24" early 2009 2.93 GhZ
    #10
    thanks guys, problem solved!

    i installed Yosemite on a 16GB USB pendrive and booted from it.
    I used disk utility and it wiped the hard disk correctly!

    i re-booted > recovery > installed Yosemite on the freshly wiped Hard Disk.

    now everythings works fine :)
     
  11. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #11
    I think I would chalk that up to Yosemite.

    Yesterday I booted and after logging in my screen started doing some sort of weird vertical scrolling like it was trying to intermix the login screen with my normal desktop. When it finally logged me in the video settings were for reduced contrast and none of my startup stuff started.

    I thought either a) the drive was dying b) my logic board was dying.

    I took out a Phoenix Boot Drive I created with Scannerz and did the following tests with Scannerz:

    1. Full scan on hard drive - PASSED
    2. Full memory test, about 10 min worth - PASSED
    3. Test I/O subsystem - PASSED
    4. SMART status showed no failures or problems of any type

    I booted into my Mavericks partition and it worked fine. I rebooted into Yosemite but this time it was normal - or at least as normal as it ever is.

    I really can't explain what happened. I've seen drives with messed up sectors do stuff like that because the CPU is given corrupt data, but now everything works. I've also seen some logic boards fail in a similar manner but they don't get better.
     
  12. WorkerBee2015 macrumors member

    Joined:
    Jan 23, 2015
    #12
    I've seen Yosemite do some things that make me think there's something wrong with the hardware as well. I think it was with System Preferences where a few times it would lock up when trying to open the main SP window.

    I've never seen this sort of bug on any earlier versions.

    Did someone at Apple who was in charge of evaluating these things quit?
     
  13. brew99 macrumors newbie

    Joined:
    Aug 7, 2014
    #13
    something similar maybe?

    Have a late 2013 imac and even before updating to yosemite, I would get major "beachball" lock ups that I would eventually have to use the power button to shutdown/restart. Lately, it has also developed a problem in that the screen would completely blackout and about 30 or so seconds later I would get the folder/file icon with the "?" flashing in the centre of the screen.

    I've tried many diagnostic programs and all report the hardware as good. A few months ago I put yosemite on a USB and booted from that, which it seemed fine, and didn't notice any problems, so this has led me to a possible HD problem. The issue only happens once in a while and I only use the mac maybe an hour per day, so sometimes I go days without a problem.

    My 1 yr applecare warranty is coming up, so do you think this sounds like an issue I should take in for them to look at. I'm just worried that they will turn it around and say they didn't notice anything unusual as it only happens once in a while.

    It is just starting to get on my nerves and is the first Apple computer I've owned, and so far hasn't left a very good impression.
     
  14. MacRobert10 macrumors 6502

    Joined:
    Nov 24, 2012
    #14
    If it works on a USB and seems to be marginal and it's still under warranty I'd take it in because it's free. It could be drive, a drive cable, or even a logic board problem.
     

Share This Page