C Compiler won't create executable

Discussion in 'Mac Programming' started by jer2eydevil88, Jan 21, 2005.

  1. jer2eydevil88 macrumors 6502


    Feb 6, 2004
    I am attempting to install Gaim on my new mac mini. So I install XCode for os 10.3 and now supposedly i have developer tools. Well look i'm new to both programming and mac os x the only practice I have with this is 1 year of C++ using Visual Studio and a bunch of time spent messing with linux that usually ended in a format and a reinstall of windows. So now that you know i'm the lame duck windows user please take pity on me.

    After reading the errors below can someone tell me how to enable my compiler to create executables. (or if someone has compiled gaim for mac *any version here people* please share as I hate ichat its bubbly... and stuff)

    Here is the log file generated by gaim as i attempt to compile it.

    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.
    It was created by gaim configure 1.1.1, which was
    generated by GNU Autoconf 2.59.  Invocation command line was
      $ ./configure 
    ## --------- ##
    ## Platform. ##
    ## --------- ##
    hostname = dhcp-140-270.sawh.uc.edu
    uname -m = Power Macintosh
    uname -r = 7.7.1
    uname -s = Darwin
    uname -v = Darwin Kernel Version 7.7.1: Mon Nov 29 19:34:12 PST 2004; root:xnu/xnu-517.10.5.obj~2/RELEASE_PPC 
    /usr/bin/uname -p = powerpc
    /bin/uname -X     = unknown
    /bin/arch              = unknown
    /usr/bin/arch -k       = unknown
    /usr/convex/getsysinfo = unknown
    hostinfo               = Mach kernel version:
    	 Darwin Kernel Version 7.7.1:
    Mon Nov 29 19:34:12 PST 2004; root:xnu/xnu-517.10.5.obj~2/RELEASE_PPC
    Kernel configured for a single processor only.
    1 processor is physically available.
    Processor type: ppc7450 (PowerPC 7450)
    Processor active: 0
    Primary memory available: 512.00 megabytes.
    Default processor set: 58 tasks, 160 threads, 1 processors
    Load average: 0.91, Mach factor: 0.38
    /bin/machine           = unknown
    /usr/bin/oslevel       = unknown
    /bin/universe          = unknown
    PATH: /bin
    PATH: /sbin
    PATH: /usr/bin
    PATH: /usr/sbin
    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##
    configure:1601: checking build system type
    configure:1619: result: powerpc-apple-darwin7.7.1
    configure:1627: checking host system type
    configure:1641: result: powerpc-apple-darwin7.7.1
    configure:1649: checking target system type
    configure:1663: result: powerpc-apple-darwin7.7.1
    configure:1693: checking for a BSD-compatible install
    configure:1748: result: /usr/bin/install -c
    configure:1759: checking whether build environment is sane
    configure:1802: result: yes
    configure:1867: checking for gawk
    configure:1896: result: no
    configure:1867: checking for mawk
    configure:1896: result: no
    configure:1867: checking for nawk
    configure:1896: result: no
    configure:1867: checking for awk
    configure:1883: found /usr/bin/awk
    configure:1893: result: awk
    configure:1903: checking whether make sets $(MAKE)
    configure:1923: result: yes
    configure:2096: checking for sed
    configure:2114: found /usr/bin/sed
    configure:2126: result: /usr/bin/sed
    configure:2186: checking for gcc
    configure:2202: found /usr/bin/gcc
    configure:2212: result: gcc
    configure:2456: checking for C compiler version
    configure:2459: gcc --version </dev/null >&5
    gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1495)
    Copyright (C) 2002 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    configure:2462: $? = 0
    configure:2464: gcc -v </dev/null >&5
    Reading specs from /usr/libexec/gcc/darwin/ppc/3.3/specs
    Thread model: posix
    gcc version 3.3 20030304 (Apple Computer, Inc. build 1495)
    configure:2467: $? = 0
    configure:2469: gcc -V </dev/null >&5
    gcc: `-V' option must have argument
    configure:2472: $? = 1
    configure:2495: checking for C compiler default output file name
    configure:2498: gcc    conftest.c  >&5
    ld: can't locate file for: -lcrt1.o
    configure:2501: $? = 1
    configure: failed program was:
    | /* confdefs.h.  */
    | #define PACKAGE_NAME "gaim"
    | #define PACKAGE_TARNAME "gaim"
    | #define PACKAGE_VERSION "1.1.1"
    | #define PACKAGE_STRING "gaim 1.1.1"
    | #define PACKAGE_BUGREPORT "gaim-devel@lists.sourceforge.net"
    | #define PACKAGE "gaim"
    | #define VERSION "1.1.1"
    | #define CONFIG_ARGS ""
    | /* end confdefs.h.  */
    | int
    | main ()
    | {
    |   ;
    |   return 0;
    | }
    configure:2540: error: C compiler cannot create executables
    See `config.log' for more details.
    ## ----------- ##
    ## confdefs.h. ##
    ## ----------- ##
    #define CONFIG_ARGS ""
    #define PACKAGE "gaim"
    #define PACKAGE_BUGREPORT "gaim-devel@lists.sourceforge.net"
    #define PACKAGE_NAME "gaim"
    #define PACKAGE_STRING "gaim 1.1.1"
    #define PACKAGE_TARNAME "gaim"
    #define PACKAGE_VERSION "1.1.1"
    #define VERSION "1.1.1"
    configure: exit 77
  2. robbieduncan Moderator emeritus


    Jul 24, 2002
    The c compiler certainly can produce executables! I think configure needs a kick. Some instructions on compiling gaim here.
  3. therevolution macrumors 6502

    May 12, 2003
    Fink is handy for installing lots of different apps, including gaim. Once it's installed (directions are on the website), you just type "fink install gaim" and, after a short wait, you're done. Fink doesn't always have the latest version of gaim available, but you said that's okay with you, so give it a shot.
  4. cwittenb macrumors newbie

    May 3, 2007
    some idea

    Although the thread is quite old, wanted to post my solution here, as
    I ran about this error message today.
    On my Tiger V.10.9.4 it seems that Xcode has set gcc v.3.22
    to the default.
    If I set the compiler to 4.0 it seems to create the executables as requested.

    In the terminal: $ sudo gcc_select 4.0

    Maybe this is still of a help to some people out there.
  5. GeeYouEye macrumors 68000


    Dec 9, 2001
    State of Denial
    Argh... thanks for solving that. I was wondering why I was having problems compiling on the command line when it worked fine in Xcode... it never occurred to me that Apple might select a different version by default.
  6. monie macrumors newbie

    Dec 1, 2010
    Thanks to everyone who posted. I've been struggling with CLISP's configure for a few hours now. IT WORKED IT WORKED AND I'M SO HAPPY.

    Sorry, I had to get that out of my system. If you're having the same problem, I recommend just getting Fink (hey, it might be useful in the future, anyway) rather than try to debug configure.

    I also had a lot of trouble getting Xcode to be my friend. Fink recommends which version of Xcode to get under Additional Things to Install according to your Mac OS version here
    and it would've saved me a helluvalotta time had I read that before trying to upgrade my OS to get the newest version, giving up, and then installing a too-early version and trying to get everything to work.

    You can download earlier versions of Xcode here:
    You'll need to register, though it's free.

    If your configure file is wacky, I saw some people who just made another one with autoconf. It didn't work with CLISP, but if you want to give it a shot, here is a tutorial:

Share This Page