cable modem blocks email-help!!

Discussion in 'Mac Accessories' started by macatprw1, Jan 10, 2009.

  1. macatprw1 macrumors newbie

    Joined:
    Jan 4, 2009
    #1
    I recently purchased a SBG900 Motorola cable modem/router to use with my IMAC. For a beginner, I found the setup instructions woefully lacking. I have managed to set up an "unsecure" wireless connection with the 900. It works fine for websurfing. I cannot however send email. When I do, I get a pop up box saying that my email connection to the Apple server on port 25 has timed out. I am able to receive email just fine. I wanted to sort this problem out before attempting to "secure" the network. I'm guessing its somewhere in the Motorola setup but I'm not sure where to start. Any suggestions?
    Thanks!
     
  2. milk242 macrumors 6502a

    Joined:
    Jun 28, 2007
    #2
    I've never heard of a home router blocking common email ports right out of the box. Are you sure you're using the right port for your email access?
     
  3. Solemony macrumors 6502

    Solemony

    Joined:
    Nov 26, 2008
    Location:
    Wonderland
    #3
    I don't think I heard an modem would do that......Are you really sure? Maybe return it if that's the problem..
     
  4. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #4
    Who is your ISP? IIRC, there are some ISPs that block port 25 to anything but their own SMTP servers (Comcast, Cox, etc). You may need to change the port your are using (if Apple supports alternate ports, try using their SSL port) or use your ISP's SMTP servers to send mail.

    Edit: It looks like Apple also has port 587 opened for SMTP (smtp.me.com) so I would give that a shot.

    You can also run several commands from the terminal in order to see if you can get a connection or not.
    Code:
    telnet smtp.me.com 25
    Code:
    telnet smtp.me.com 587
    If the connection is good you should see the following line printed after hitting enter
    Code:
    Trying 17.148.16.31...
    Connected to smtp.me.com.
    Escape character is '^]'.
    220 asmtpout024.mac.com -- Server ESMTP (Sun Java(tm) System Messaging Server 6.3-7.03 (built Aug  7 2008; 32bit))
    If you don't see anything for 10-15 seconds, you probably can't connect and you can exit telnet by hitting Control-] then Control-C
     
  5. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #5
    The cable modem isn't blocking 25--unless you configured it to do so--and by the error message that's not the case.

    As has been noted, it's your ISP. Try changing your SMTP ports in the mail account settings to 587 or 995. Those are the most commonly used; in fact, Cox suggests 587 in their support pages (or used to anyway).
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    Have you shared the serial number and MAC address of your new modem with your ISP?
     

Share This Page