CalDav & CardDav ios 7

Discussion in 'iOS 7' started by mcflyy, Oct 22, 2013.

  1. mcflyy macrumors newbie

    Joined:
    Oct 22, 2013
    #1
    Hi all,
    I am having problems with caldav and carddan since I updated to 7. I am now on 7.0.3 hoping the issue is fixed. It's not.
    I am using AfterLogic caldav server and also tested BaiKal server. Both, using profiles and manual setup won't work. No addtl. calendar will show up. Between my server and any caldav compatible client on PC or Mac I do not have any issues. Back on version 6 everything works flawless.
    Note: I am NOT talking about google sync!
    Any suggestions?
    Thanks
     
  2. jzw95 macrumors newbie

    Joined:
    Oct 25, 2013
    #2
    Hi mcflyy,

    Can't help you with CalDAV, but I just got CardDAV working with Baikal and iOS 7.0.3. What is the URL you are entering when testing the manual setup with the Baikal CardDAV server? It took me a while to figure out, but you need to use something along the lines of:

    Code:
    http://server.com/card.php/principals/username/
    Obviously replace 'server.com' and 'username' with your server and username, respectively.

    I have Baikal installed in a subdirectory on my server, so my URL has '/baikal/' after the domain name:

    Code:
    http://linden.local/baikal/card.php/principals/jolin/
    I'm not using SSL, so the port is set to 80. All working on iOS 7.0.3.

    Cheers,
    Jolin
     
  3. mcflyy thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #3
  4. jzw95 macrumors newbie

    Joined:
    Oct 25, 2013
    #4
    What URL did you enter in the CardDAV settings?

    I found the settings in the official instructions don't work for iOS 7.
     
  5. mcflyy thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #5
    My URL is:
    domain.com/baikal/card.php/name/
    I cannot use http:// because it won't connect.
    With these settings I get the connection but for some reason cannot sync or push something to the baikal server.
    It works great for calendar.
    Any ideas?
    Thanks
     
  6. mcflyy thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #6
    and /principals/ of course
     
  7. jzw95 macrumors newbie

    Joined:
    Oct 25, 2013
    #7
    In the Settings app, under ‘Mail, Contacts, Calendars’, go to the Baikal CardDAV account that you’ve set up. From here, click on ‘Advanced Settings’ and make sure the Account URL is correct. For some reason, iOS 7 often messes this URL up even if you entered it correctly when setting up the account. If you correct it in the Advanced Settings and then try to save the account, you will get an error when it tries to verify the settings. Just ignore the error and save the changes anyway (and ignore the warning about the account not syncing). It should work. Make sure you the Account URL in Advanced Settings is:

    domain.com/baikal/card.php/principals/name/

    Also make sure that your SSL settings are correct (e.g. disabled if you don’t have SSL enabled on the server or enabled if you do) and your port setting (443 for SSL, 80 if not). Both of these are also in Advanced Settings.

    Cheers,
    Jolin
     

Share This Page