Calendar Keeps Turning on Notification via E-mail

Discussion in 'Mac Apps and Mac App Store' started by DanielGMac, Jan 19, 2017.

  1. DanielGMac macrumors newbie

    DanielGMac

    Joined:
    Jan 9, 2011
    #1
    I have a few OS X machines, an iPhone, etc.
    Whenever I have something that I want email notification for, oh I don't know... "payday" let's say, I get an email from every single machine and phone I have.

    I go in and change every one of them to have "On My Mac" and "None" for all the alert stuff except for one machine.

    So it looks like:
    calendarnotification1.png






    Every single time the OS is updated, all of the calendars revert to:




    calendarnotification2.png


    and I get a flood of "Payday" notifications until I go back and turn off notification on all the machines except for the one.

    How can I make the "Shut up unless I tell you otherwise" stick over OS updates?

    Thanks
    DanH
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Are you sure you're getting a separate email from your phone? I don't think so...but...

    In your Mac's Calendar app, Control-Click (right click) the offending calendar in the calendar list on the left. Select "Get info" and then check "Ignore alerts".

    I hope you can find a satisfying combination of settings between all of your devices.
     
  3. DanielGMac thread starter macrumors newbie

    DanielGMac

    Joined:
    Jan 9, 2011
    #3
    These aren't notification alerts, these are emails. Every time it happens I view full headers of the email, look at the originator's ip address and go hunt down (virtual) the offender and change the calendar back to no alerts. Yes, it's from the phone, iMac, Mac Mini, other Mac Mini, MacBook Pro, iPhone, etc. Some of these are work machines for those wondering. Every time there's an update that includes the calendar, I get a flood of email notifications from each machine, including the phone.

    "Ignore alerts" only ignores the notification on that particular mac. Does nothing to block emails going out from the local calendar.

    I do appreciate the reply. I'm hoping this is something that's known and someone has figured out what to do.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    I know I've tinkered with email alert settings at some point in the past but I don't really remember everything I found out but I'm pretty sure the conclusion I reached was that I didn't want to use them. For one thing, the computer has to be running for the alert to occur as it's not a server-based operation.

    These Mac Mail calendar alerts seem to be a relic from when calendar syncing between machines wasn't prevalent. Now that it is, this is what you get.

    I'm thinking if, on the Mac, you don't have "Make this my Card" selected for yourself in Contacts, the emails can't go out.

    I don't get these alerts from my iPhone on iOS 9. Only from Macs.
     
  5. msvadi macrumors 6502

    Joined:
    Aug 12, 2010
    #5
    I'm dealing with the same issue. If I choose "Ignore alerts" for a calendar, it stops sending email alerts. Unfortunately, it also stops displaying Calendar notifications in the Notification Center. Is it supposed to behave like that? I want to stop email alters, but I still would like to see calendar notifications on the screen of my macs. Is it possible?
     

Share This Page