Calendar notifications show up double

Discussion in 'iPhone' started by Moonfacej, Apr 9, 2012.

  1. Moonfacej macrumors newbie

    Apr 6, 2012
    When I pull down the notification center I see my calendar entries twice. I've tried turning of the iCloud calendar in the calendar app, but it did not change anything. Only selecting the iCloud calendar did not help either. Anyone know what might be causing this?
  2. Mom3Virtual macrumors newbie

    Apr 16, 2012

    To stop getting a double entry in your calender, tap on your calender; tap on calender at the top left; only one calender type should be checked
  3. Sunsean macrumors 6502

    Mar 27, 2012
    Unfortunately, this 'select only one calendar' option only works for the actual calendar app. If you still have the 'unused' calendars on your phone, they will still show up in the notification center.

    I found a way to fix this by going through all my accounts and deleting duplicate calendars. It gets a little confusing, because I have my google calendar, fb birthday calendar, outlook account, plus all the 'on my phone' and 'icloud' calendars...I managed to get them down to only 1 entry per event, but when I plugged my phone into the computer to sync, it reset to whatever settings it had been and I'm back to repeats in the notification center. I'm sure it can be permanently fixed by adjusting settings and deleting unused/repeat calendars...just haven't taken the time to do it.
  4. Nickjones2 macrumors newbie

    Apr 24, 2012
    I had the same problem. Here is the solution:

    (1) Sync your iPhone with iTunes

    (2) On the iPhone part of iTunes click on "Info"

    (3) Unselect sync calandars.

    (4) Press sync.

    (5) Done.
  5. joeblow9104 macrumors newbie

    Nov 5, 2012
    Did this help you guys??
    It didn't help me... That option isn't even selected on my pc.
    I have an exchange calendar and google both syncing. Even though the calendar app only shows the calendars I want to see, i.e., the ones I've selected, the notification center and the calendar app don't seem to communicate.

Share This Page