Calendar problems with Google Calendar?

Discussion in 'OS X Yosemite (10.10)' started by varxx, Jul 24, 2014.

  1. varxx macrumors newbie

    Joined:
    Dec 12, 2012
    #1
    Is anyone else having trouble getting Calendar to connect to their Google Calendar?

    I consistently get "Calendar can't connect to the Google account 'Gmail'," with a request for me to enter my password. When I enter it, the dialog reports "The server responded with an error."

    All is still working fine on my Mavericks machine, so I'm assuming this is a Yosemite problem.

    I tried disabling and re-enabling my Google account in Calendar / Accounts. That didn't help.
     
  2. varxx thread starter macrumors newbie

    Joined:
    Dec 12, 2012
    #2
    Apparently an Apple Fairy just touched my machine with a magic wand, because Yosemite's Calendar app finally started linking properly to my Google Calendar.

    I had tried all kinds of things to no avail. Just now, though, I left the error dialogue (which was asking for a password) on the screen for maybe 15 minutes. Suddenly Calendar decided to behave.

    I'm considering this glitch unglitched.
     
  3. mrubioroy macrumors newbie

    Joined:
    Aug 11, 2010
  4. Kevin Purcell macrumors newbie

    Joined:
    Nov 7, 2010
    #4
    Anyone find a fix besides luck?
     
  5. phphreak macrumors member

    Joined:
    Nov 7, 2009
    #5
    I'm having the same problem. I have 2 factor authentication enabled on my google account, so I put a one time app password for Google Calendar on the mac. It initially works, and then asks me for a password soon after.
     
  6. gmtroberts macrumors newbie

    Joined:
    Sep 13, 2014
    #6
    Same issue too. I just changed my Google password the other day, and it works on my Mavericks machine but not on my Yosemite beta one. I went through System Prefs -> Internet Accounts to change my password for Google, but Calendar still complains. I guess Google has a different server to authenticate to for their calendars?
     
  7. derekleif macrumors newbie

    Joined:
    Sep 26, 2014
    #7
    A Fix for the dreaded "The Server Responded With an Error Problem"

    Folks,

    Okay, this may not work for all of you, but it worked for me:

    Often--I think in the interest of security--an application such as Calendar will only work when you enter something called "An Application Specific Password."

    This is not the same as your basic Google password. It is a one-time password that you must generate by going to, you guessed it, The Application Specific Password page.

    The link below has a detailed explanation of all of this. Also, it has the link to get to that all-important Application Specific Password page. First, I've listed the four steps describing what you need to do. Then, after these steps, I've inserted the link.

    1) First, get to that all-important Application Specific Password page. On the page you'll see after you click the link below, you'll see that the second heading is Generating Application Specific Passwords. You will see two drop down menus. One says "Select App," and the other says "Select Device."

    2) Choose the program that's giving you trouble, and choose whatever device is giving you that funky error.

    3) At that point, it will generate that all-important 16-character password, which will be in black letters on a yellow background. Copy this, and paste it into the password box on Calendar (or Mail, or whichever program is being ornery). Then cross your fingers (as I said, it worked for me, and I hope it works for you).

    4) Be sure to close out the box that had that Application Specific Password.

    Okay, now that you've read all my jibber-jabber, here's that link to the "Generating Application Specific Passwords" page:

    https://support.google.com/mail/answer/1173270?hl=en

    Again...this bulletin board has been SO HELPFUL to me on a number of occasions. I hope, that with this post, I've been able to give something back.
     
  8. krsnendu macrumors newbie

    Joined:
    Dec 3, 2014
    #8
    I have set up app specific password but it is not being accepted.
    When I try to use my regular password it asks for the app specific password.

    Anyone found a fix for this?
     
  9. runimoni macrumors newbie

    Joined:
    Jun 10, 2014
    #9
    Unfortunately I don't have a proper solution but I had the same problem until I got an email from google saying they blocked a connection attempt to my accounts.
    When I entered my password again in Calendar in Yosemite, it synced and started working properly again.
    Hope you find a solution to your problem !
     
  10. m_chelle_b macrumors newbie

    m_chelle_b

    Joined:
    Jun 1, 2016
    #10

    Thank you so much! This fixed my problem straight away.
     

Share This Page