Calendar won't auto sync in background...?

Discussion in 'iPhone' started by tman1425, May 17, 2012.

  1. tman1425 macrumors member

    Joined:
    Jun 23, 2010
    #1
    Whenever I add a calendar event on my iPhone or iPad, it will only show up on the other iOS device after I open the calendar app. This has been a big problem because my calendar alarms won't go off on my phone if I haven't opened the app in order to sync the new events.

    Aren't they supposed to automatically show up on each device without having to open the calendar app first? Does anyone know what's wrong? I've also tried restoring as new on all my devices.

    Any help is appreciated. Thanks in advance.
     
  2. tman1425 thread starter macrumors member

    Joined:
    Jun 23, 2010
    #2
    Bumping to the top. Does anyone have any suggestions? Is it not supposed to automatically sync? I always thought that was the point of it.....?
     
  3. aliensarecool macrumors 6502a

    aliensarecool

    Joined:
    Feb 25, 2012
    #3
    what if you schedule a push/fetch time? i saw one option saying 'will take place when app is in use'
     
  4. applefanDrew macrumors 65816

    Joined:
    Jul 17, 2010
    #4
    make sure iCloud is set to push. It does update in the background. Though I have noticed sometimes it hasn't. But over 6-7 months, that has happened maybe 2-3 times.
     
  5. tman1425 thread starter macrumors member

    Joined:
    Jun 23, 2010
    #5
    It looks like I got it working. I guess iCloud doesn't support push for calendar events :confused:. I originally had it set to push with fetch set to manual. It never synced until I opened the app. I now changed iCloud to have a fetch time of 15 minutes and it now auto syncs every 15 minutes without having to open the app first. Thanks for the suggestion!!!
     

Share This Page