Call forward symbol always shows after reboot.

Discussion in 'iPhone' started by Mike Boreham, Oct 8, 2013.

  1. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #1
    After a reboot my phone always has the call forward symbol showing at top left. Call forward is not on (calls are not forwarded) and if I go to Settings/Phone/Call Forwarding it is shown as not on, but the act of going there causes the forwarding symbol to disappear.

    Anyone else see this?

    Suspect it might be something to do with restore from my old iPhone 5 instead of setting up as new. Not a big issue but mildly annoying.
     
  2. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #2
    For the record I found the solution to this problem here.

    It seems to be network related, in my case Three in the UK, but others have the problem, and is nothing to do with iOS 7 or iPhone 5s. I was new to Three at the same time as iPhone 5s.
     
  3. Bluemustang macrumors newbie

    Joined:
    Oct 11, 2013
    Location:
    USA
    #3

    You can try this: setup call forward, make a test call to see that it is indeed forwarded, then turn off call forward. That might toggle the carrier's call forward indication. I've had the same thing happen to me before on a non-smart phone, and I did the above to clear it.

    This might clear the CF indication for good, even after reboot. Hope it works for you.
     
  4. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #4
    Thanks Bluemustang...that is more or less what i did as per the link in my post #2 above and which solved it for me. The only difference is that the link also suggested turning the phone off between the stages.
     
  5. McRumour macrumors member

    Joined:
    Oct 6, 2013
    #5
    iPhone 5s Call-Forwarding weirdness

    Ditto to above....
    Exactly the same is occurring on brand new iPhone 5s - which I just received and set up yesterday.
    To add to the weirdness - I have a pre-paid T- Mobile Plan which does not even include call-forwarding at all. I've checked with them; they say it's definitely an Apple software issue.
    Apple tech support say restoring to factory settings is the way to try to correct this problem. I'm unwilling to do this at the moment - as I've just invested too much time in setting up the phone (only yesterday). They say I'd definitely lose many of these settings - including special DNS number strings which I've added to my Network settings, passwords etc......and would have to set them all over again
    I've tried the solution suggested in this thread and what's been suggested on the AV forum website, where the issue was also addressed....
    When I go to Settings/Phone/Call Forwarding.....and then add either my land line number or even my Google Voice number - it makes no difference - the icon reappears when I turn on phone again, after having completely shut it down.
    And yet, when I then return to settings after the phone "re-boot" - it shows it to be turned off. And, as before, the act of going there - serves to remove the icon.
    And btw: If I hit the back button immediately after entering my landline or Google Voice number....although it shows call-forwarding is turned on (the button is now sort of grey-green (like it's on but not on)
    and....the above occurs ad nauseum.........
    Any ideas anyone??????
     
  6. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #6
    It wasn't clear from what you said whether you actually made a call to your phone while call forwarding was on? The steps in the solution which has worked for many included this.
    I would doubt that factory settings would fix it, as all the indications are that it is network related.
     
  7. McRumour macrumors member

    Joined:
    Oct 6, 2013
    #7
    Yes I did - I called my home phone land line. It immediately rang that phone.
    Furthermore - (as I think I mentioned in my first post ?).....my settings fail to retain that landline number (or any number I try to type into the Call Forwarding field). By that I mean:
    If I hit the blue back button at top of the "Forwarding To" page (where I've just finished typing my landline number)....and immediately return to the "Call Forwarding" page - the on/off button shows up as grey again (turned off) - despite my having just set call forwarding to ON, by entering landline number!
    (Utterly dizzy-making, isn't it :( )
    BTW: what do you mean, Mike, by "network related"?
    Are you referring to my cell carrier (which is T-Mobile)? Because I've already called them...and, as I mentioned before, they say it this issue has nothing to do with them - as Call-Forwarding is just not an available feature on my account.

    Further "fix-it" thoughts? :confused::confused::confused:
    Thanks in advance for any possibly helpful input......
     
  8. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #8
    Yes by network related I did mean cell carrier related. However since your behaviour is a little different in that the Call Forward setting and number doesn't stick, then maybe a factory reset might work. If you back up first you can always try it, then if it doesn't work, restore from your backup.

    Maybe try a few repeats?...sometimes these things don't work first time.
     
  9. McRumour macrumors member

    Joined:
    Oct 6, 2013
    #9
    alas.......I've even repeated the repeats. Result: consistent failure
    I do want to find a solution, if possible, short of "factory reset" - and losing all my settings - because I'm aware of what that entails.......
    Mr. Apple :apple:.....are you out there? Hey.... help, help.....?????
     
  10. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #10
    You won't get any response from Apple here, but you could try Applecare or an Apple store.

    The alternatives are to live with it (how often do you reboot the phone anyway?).....or try a factory restore. If the factory restore solves it you then have the choice of reloading your settings etc,......or restoring from your backup to where you were.

    The problem is not at all common.
     
  11. McRumour, Oct 31, 2013
    Last edited: Oct 31, 2013

    McRumour macrumors member

    Joined:
    Oct 6, 2013
    #11
    ¡¡¡Issue resolved!!!:):):)

    Got a phenomenal senior level Apple Iphone tech support person on the phone yesterday.
    She really pulled out all the stops on my behalf....first by contacting the mysterious behind-the-scenes apple-engineers and somehow getting a response back from them within 30 minutes!
    And then (while I was still on-hold) actually calling T-Mobile on my behalf - about my issue and eventually getting through to a Tech supervisor here in the States (which, in itself, took some doing)
    It was decided by them that before my going to the extreme of the "nuclear option" wipe-out of the phone - I should just go to a local T-Mobile store and ask that they replace my sim card.
    Which is what I did today.
    And it worked.
    No more phantom icon inhabiting my 5S status bar every time I shut down and then re-start the phone.

    I'm totally :) now with my glitch-free new :apple: toy
     
  12. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #12
    Very interesting! Persistence paid off. Glad you're sorted.
     
  13. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #13
    This bug seems to have returned in iOS7.1

    Heven't jumped through the hoops to solve yet.
     
  14. Mike Boreham thread starter macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #14
    On further testing this may only have happened on first start up after the update. I toggled call forwarding on, and it stuck on "loading" so I turned call forwarding off and the symbol had gone. Rebooted and it is still gone.
     

Share This Page