Call forwarding and call waiting with AT&T [SOLVED]

jpiszcz

macrumors 6502
Original poster
Mar 28, 2010
332
65
Hello,

I was curious if anyone uses call forwarding and/or call-waiting with AT&T?

Using an iP6+ and noticed when I turn either option on-- exit out and then go back, it is off again. Further, when I try to enable call forwarding it cannot update/fails to update. I also tried the **21*num# method and that way fails too. Was curious if anyone had seen this before?

- I've tried resetting network settings and to no avail. AT&T said they have never heard of that problem before.

Thanks,

Justin.
 
Last edited:

wongster

macrumors regular
Sep 27, 2014
146
6
always had my call waiting on with other iPhones. looked in settings on my iPhone 6 and it was off. toggled it on no problem and exiting out and back in, it stays on. tried call forwarding with my house number and that saved also without any issues.

are you on os8.1? if all else fails, bring it into at&t and have one of them look at it.
 
Last edited:

jpiszcz

macrumors 6502
Original poster
Mar 28, 2010
332
65
always had my call waiting on with other iPhones. looked in settings on my iPhone 6 and it was off. toggled it on no problem and exiting out and back in, it stays on. tried call forwarding with my house number and that saved also without any issues.

are you on os8.1? if all else fails, bring it into at&t and have one of them look at it.
Hi-- yup on iOS 8.1 also did a complete wipe, erase all content and settings, to no avail, will follow-up with AT&T, thanks.
 

jpiszcz

macrumors 6502
Original poster
Mar 28, 2010
332
65
Problem solved.

Problem SOLVED 10/23/2014!

So I moved the SIM from my iPhone 6 plus to my previous iPhone 5S, I was able to see the forward when AT&T set it for me (I asked them to because I needed it forwarded and was unable to do it). When I put the SIM back in my iPhone 6 plus it showed the forwarding icon on the top left; however, I could not update it.

So then.. there was only one last thing (I thought) it could be.. I asked AT&T to update the IMEI of the new iPhone 6 plus, when I checked with AT&T—it was still tied to the old IMEI number of the iPhone 5S.

Once AT&T associated the new IMEI with the (account/SIM?)—per AT&T I powered off the phone and turned it back on and voila problem fixed and everything is working!

I hope this helps someone if they transfer their old nano SIM from an iPhone 5/S to a 6/6plus and runs into this issue!

Justin.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.