Call forwarding icon

Pagemakers

macrumors 68020
Original poster
Mar 28, 2008
2,441
723
Manchester UK
Since upgrading to iOS 6 the call forwarding icon randomly appears. If I call my phone, the call is not forwarded to another number so I am assuming the icon is spurious.

It's happening to my mate's phone too.

Anybody else?
 

dan.1986

macrumors newbie
May 9, 2012
5
0
Same here, its driving me nuts! I've restored from scratch and that doesn't solve it either.
 

Fatboy71

macrumors 65816
Dec 21, 2010
1,199
140
UK
Mr

Since upgrading to iOS 6 the call forwarding icon randomly appears. If I call my phone, the call is not forwarded to another number so I am assuming the icon is spurious.

It's happening to my mate's phone too.

Anybody else?
I'm on O2 (UK) and I solved it by doing the following. Other networks will be different.

Firstly dial 1760 to switch off your voicemail.
Now dial 1750 to switch voicmail back on and use the below divert codes to setup your voicemail to take messages in the following instances (depending on your preference).

Not reachable (For example when the phone is switched off or out of signal/service)
To activate= **62*901#
To cancel= ##62#
To check status= *#62#


Busy (For example when your engaged on another call, or you reject an incoming call)
To activate= **67*901#
To cancel= ##67#
To check status= *#67#


No Reply
To activate= **61*901*11* number of seconds #
The *11* only needs to be entered if you wish to set the length of time the phone rings before diverting to voicemail. The standard ring time is 30 seconds but you can have anything from 5 seconds to 30 seconds (in increments of 5) by using the *11* method.

To cancel
# # 61 #

To check status
* # 61 #


After doing the above, you can then do the below to stop the Call Forwarding phone icon appearing when the iPhone is switched on.

1: On your iPhone, go into Settings/Phone, touch Call Forwarding.

2: Next switch Call Forwarding on.

3: You will now see "Forward to". Touch this and enter 901 (this is O2's voicemail number). Once you have done this, touch the left pointing CALL FORWARDING at the top left of the screen.

4: Now switch off Call Forwarding.

You should now not see the Call Forward icon appearing.

I can confirm that I had the Call Forwarding icon appearing everytime I switched my iPhone on, and I managed to get rid of it by doing what I have mentioned above.