Call of Duty 2 Mac App Store "Key Code in Use"

Discussion in 'Mac and PC Games' started by PROTOTYPE10, Aug 16, 2011.

  1. PROTOTYPE10 macrumors newbie

    Joined:
    Aug 16, 2011
    #1
    I recently bought call of duty 2 from the mac app store and the single player works fine and everything but when I tried to join a multiplayer server it said "Key code in use, please try reconnecting later". It's been 2 days and I still haven't been able to join a multiplayer server. Anyone else having this problem?
     
  2. Sambo110 macrumors 68000

    Joined:
    Mar 12, 2007
    Location:
    Australia
    #2
    I did with Call of Duty 4, but then I read a review telling me how to fix it and it worked properly.

    1. Go to User/Library/Preferences
    2. There is a file named com.aspyr.callofduty4.plist (I assume this will be the same name, just with "Call of Duty 2" for you)
    3.Delete the file. Deleting it will apparently delete your single player save files, though I'm not sure about that. But it definitely fixed the issue in CoD4 for me.
     
  3. PROTOTYPE10 thread starter macrumors newbie

    Joined:
    Aug 16, 2011
    #3
    yeah I've actually already tried that, should have said it in the original post but it didn't work.
     
  4. GabrielinDaStre macrumors newbie

    Joined:
    Aug 21, 2011
    #4
    Call of duty 2 key code in use...HELP! (Mac)

    I have just bought call of duty 2 on the mac app store. I went directly to play the online multiplayer but it said the key code is in use. I have not been able to play and I am really getting frustrated. There is a file called com.aspyr.callofduty2 i have tried deleting it but when I relaunch the game it appears again. I have contacted aspyr support but they do not reply. Help pleasE!
     
  5. Bchagey macrumors 6502

    Joined:
    Feb 10, 2011
    #5
    if you find a fix please let me know, I'm having the same problems.
     
  6. markusmac666 macrumors newbie

    Joined:
    Apr 8, 2012
    #6
    So frustrated too!!!

    I bought the game on AppStore on my Mac as well, and i have the exact same error. Looking for help from activision, seems like it isn't giving me any answers at all!

    you really feel like a fool, when you buy the game, and you get the message, that your key-code is in use :-(

    btw. when i type my key-code into "options"
    it says:
    "key-code seems to be valid"

    it doesn't make any sense :mad:
     
  7. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  8. Markovich macrumors newbie

    Joined:
    Jul 22, 2008
    Location:
    Central Ohio
    #8
    Try going to your Application Support folder and deleting any custom maps or mods you may have downloaded.

    This happens in COD and CODUO if you have too many custom maps/mods in your COD ( or CODUO) folder under Application Support.
     
  9. adildacoolset macrumors 65816

    Joined:
    Sep 5, 2011
    Location:
    Lusaka, Zambia(If you know where it is)
    #9
    This isn't supposed to happen. Apps with their own activation methods would be rejected. So contact the support for aspyr. If unlucky, contact itunes
     
  10. Sebastian72 macrumors newbie

    Joined:
    Jul 31, 2012
    #10
    hi everyone i have the same problem. Can someone help me please
     

Share This Page