Call of Duty 4 heat distortion rendering problem

Discussion in 'Mac and PC Games' started by nconnella, Jun 23, 2009.

  1. nconnella macrumors regular

    Joined:
    Nov 1, 2008
    #1
    Hello, I am playing COD4 on a unibody 15" macbook pro, everything looks great on max setting ACCEPT for when I put anti-aliasing on, my video card renders "heat distortion" such as heat coming off a fire, a big gun, from behind the tank as a bizarre reversed mirror reflection of my POV. I wish I could upload a pic. Is anyone else experiencing this and know how to fix it? It becomes quite annoying as it completely blocks my view if I'm standing in front of "hot air". I can't see through it when I should be able to. It doesn't happen when anti-aliasing is off... is this a glitch, my computer, or am I doing something wrong? Thanks!
     
  2. fcamilleri macrumors member

    Joined:
    Jun 7, 2009
    Location:
    In Your Mind
    #2
    It seems that mac GPU's are pretty hostile to AA. I can have most options on max, but the second I lower everything to medium and turn on AA, it craps out.

    Im on an imac, 4gb memory 512 mb gpu
     
  3. voyagerd macrumors 65816

    voyagerd

    Joined:
    Jun 30, 2002
    Location:
    Rancho Cordova, CA
    #3
    Yeah, the index of refraction for heat distortion is all messed up for the Mac version of COD4. Did heat distortion come on automatically for you? I had to enable it in the config file to see it.
     
  4. nconnella thread starter macrumors regular

    Joined:
    Nov 1, 2008
    #4
    it was automatic. I watched a video on youtube how the newer macbook pros can handle almost all settings on high including AA so I turned it on. Then I noticed anywhere there was a heat wave, all I saw was an upside down image of my my POV (my gun etc.) really weird. But when I turn AA off it disappears. So I guess it's just a glitch in the port or something. Now I have to decide whether I want to see that, or jagged edges because besides the heat waves it looks SO much better with AA on.

    Also, has anyone applied the 1.7.1 patch? for some reason for me, it only says it's updated on my multiplayer home screen. On the single player home screen it still says 1.5.549. Is this normal? Does the patch do anything for single player?
     

Share This Page