Call of Duty 4 Multiplayer Cannot find servers!

Discussion in 'Mac and PC Games' started by abyung, Jan 25, 2009.

  1. abyung macrumors newbie

    Joined:
    Jan 25, 2009
    #1
    Cannot find any servers in Multiplayer. Using a Macbook (white).
    Any help would be appreciated. I have tried everything I can think of and ASPYR is no help.
     
  2. Kaos Theory macrumors member

    Joined:
    Nov 9, 2008
    #2
    A Good Server

    You should try downloading Gameranger, which has a compilation of all the servers for Mac games. I know that Tribulation Force has a COD4 server, and would highly recommend it, as Tribulation Force provides a friendly and respectful gaming environment.
    Call of Duty 4 on a WhiteBook?!? How many FPS are you getting? My brother owned a white MacBook and bought Call of Duty 2 instead of 4 out of worry of not being able to run it. I heard that in tests the WhiteBook got only around 8 FPS. Is it less choppy for you?
    Oh, if you plan on playing multiplayer, you should buy a mouse if you don't already own one. It kills to have to use a trackpad in close quarters. Hope this helps, and have fun! :D
     
  3. djkirsten macrumors regular

    Joined:
    Nov 3, 2006
    #3
    did you get the updates? the version you buy isnt the most updated and thus all the servers have updated (you wont see the servers if they are updated)
     
  4. MDuckworth macrumors newbie

    Joined:
    Jan 28, 2009
    #4
    i to have the same problem anyone know how to fix this? I also downloaded game ranger when i run it and join a server it says something about the key code and then times out.
     
  5. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #5
    do you have the latest update..?

    servers who run latest versions cannot be seen in previous versions
    so basically
    if you have lets say 1.5 you wont see 1.7 version servers :p
     
  6. MDuckworth macrumors newbie

    Joined:
    Jan 28, 2009
    #6
    Yes i have installed the 1.7 patch. I can not figure this out. i have been work on it for 3 days now.
     
  7. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #7
    what about the Filter section..?
    if all this doesnt work call Aspyr, or apple.

    ah there was one problem i had with C&C 3 occuring like this although it has nothing to do it cod4 but it might help you out so.. on C&C 3 i could run the settings on ultra high with AA x3 and run it smooth but all the sudden on multiplayer it started to lag and such so i didnt know what the problem is and when i turned it down it worked perfectly.. try this out with cod 4? i know this has nothing to do with it but just trying to throw idea out there :p.
     
  8. MDuckworth macrumors newbie

    Joined:
    Jan 28, 2009
    #8
    I have tried everything. I have called both of them. I think i will just take it to the apple store sometime. Kind of sucks i payed 44 so i could play this game online and i cant get it to work.
     
  9. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #9
    sorry to hear that : (.

    i just thought of a new solution That Might work i dont know if it will but give it a try.

    go Portforward the Cod 4 and maybe that might work or use direct cable line if your using router.

    but if you arent using a router then i have no idea..
     
  10. arjun747 macrumors newbie

    Joined:
    Dec 4, 2009
    #10
    Ive just Bought Call of Duty 4 Mac - and i installed 1.7 cant 'join server'
    i uninstalled it and used 1.5 still couldnt, and i cant even connect to a server with direct IP. it says Server Connection timed out PLEASE Someone help
     
  11. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #11
    So you see servers and can't join them? Man that sounds sucky. I have it for for Windows through Bootcamp and haven't had that problem, but I wish I had some advice.

    I think you should just harass Aspyr until they give you a working answer. You paid them good money for a game that's famous for online multiplayer, it should damn well work for you.
     

Share This Page