Caller id won't toggle

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Reemani, Jan 21, 2011.

  1. Reemani macrumors newbie

    Joined:
    Jan 21, 2011
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Hi there!
    My iPhone 4 won't let me toggle my caller id On/Off it appears grayend. Is there any chance you can help?
    Thanks.
     
  2. lapocompris macrumors regular

    Joined:
    Jun 26, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    That means you can't make anonymous call...
     
  3. Reemani thread starter macrumors newbie

    Joined:
    Jan 21, 2011
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    yeah I was just wondering if I can enable it?
     
  4. Reemani thread starter macrumors newbie

    Joined:
    Jan 21, 2011
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    I mean disable it
     
  5. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #5
    That is a carrier feature and if you do not see it (or are unable to change it) then your carrier does not support it.

    However there might be other options to hide the caller id for your outgoing calls... Contact your carrier on how to do that, it might involve typing an additional * or # and a 2 digit number before the phone number you are calling. But your carrier would know more on that.
     
  6. japinch macrumors newbie

    Joined:
    Feb 15, 2012
    #6
    caller id wo't toggle

    Turn the airplane mode on and then off-this disables the caller id -then go to caller id and it should toggle-it worked for me
     

Share This Page