Calling Chrome Users

Discussion in 'MacBook Air' started by A4orce84, Feb 6, 2016.

  1. A4orce84 macrumors regular

    Joined:
    Apr 17, 2012
    #1
    Anyone using Chrome, specifically the Chrome Beta on here?

    Have a few questions, and hitting some issues....

    Thanks,
    Asif
     
  2. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
  3. Strider64 macrumors regular

    Strider64

    Joined:
    Dec 1, 2015
    Location:
    Suburb of Detroit
    #3
    Being a web developer/designer I never use beta for I have enough glitches as it is. :D
     
  4. DesignerOnMac macrumors 6502a

    DesignerOnMac

    Joined:
    Jul 23, 2007
    #4
    I had Chrome on my Air, but it was a rehouse hog and added adware that was a pain in my butt!
     
  5. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #5
    I use Chrome on everything, my Macs, iPhones and iPads, Androids and Windows machines very successfully. It's preferable over any other browser including Safari, which I continually approach with an open mind, but is disappointing. Usually I run both versions, one being beta, on my MBPr. However Due to an extra heavy work load, I haven't used a current beta for the last 90 days
     
  6. A4orce84 thread starter macrumors regular

    Joined:
    Apr 17, 2012
    #6
    Hey Guys,

    So I'm seeing a weird issue when trying to use the Chrome Beta. It appears that it's not really using the Chrome Beta version as far as I can tell.

    Here is a bit of background info:

    Background:
    2013 MacBook Air 13"
    OSX El Capitan (10.11.3)
    Chrome Beta --> https://www.google.com/chrome/browser/beta.html

    The Issue:
    When I check the "version" of Chrome, to confirm I am using the beta version, I'm seeing the following:

    MacBook Air:

    About Version --> https://www.dropbox.com/s/6q9vqt8ses01vr7/Screen Shot 2016-02-07 at 12.55.54 PM.png?dl=0
    Chrome Official Version --> https://www.dropbox.com/s/a3z61qt8wqkxxmb/Screen Shot 2016-02-07 at 12.59.09 PM.png?dl=0

    Notice it does not say anything about "beta". And even the "Chrome Official Version" says "offical build." This is compared to my Retina Macbook Pro, which displays everything correctly:

    Retina MacBook Pro:

    About Version --> https://www.dropbox.com/home/Screenshots?preview=Screenshot+2016-02-07+13.31.35.png
    Chrome Official Version --> https://www.dropbox.com/home/Screenshots?preview=Screenshot+2016-02-07+13.31.45.png

    As you can see it says "Beta" in the rMBP screenshots. So, my guess is for some reason Chrome is corrupted or not really on the Beta Channel on my MacBook Air. I tried the following guide to completely remove Chrome from my OSX Installation:
    http://crunchify.com/how-to-purge-all-your-google-chrome-user-data-on-mac-os-x/

    I tried reinstalling the Chrome Beta, and once again I had the same screenshots with the MacBook air that I posted above.

    Assistance:

    Can someone with a MacBook Air go and download the Chrome Beta, and tell me what you see in the "About Version" and "Chrome Official Version" information please?

    Any additional assistance or help would be greatly appreciated. TIA!


    Thanks,
    Asif
     
  7. A4orce84 thread starter macrumors regular

    Joined:
    Apr 17, 2012
  8. sracer macrumors 603

    sracer

    Joined:
    Apr 9, 2010
    Location:
    Land of Bongos and Beatniks
    #8
    I used to use Chrome everywhere, but because of its hog-like tendencies, I switched to Opera on all my devices... all the same extensions that I used in Chrome as well as bookmark/password syncing.
     
  9. A4orce84 thread starter macrumors regular

    Joined:
    Apr 17, 2012
    #9
    Can someone please help me with the above 'test' if possible? Just looking to see if anyone can confirm they are seeing the same version information.

    TIA!
     
  10. cerberusss, Feb 8, 2016
    Last edited: Feb 8, 2016

    cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #10
    I uninstalled Chrome, then installed the beta from your link. This is on a MacBook Air 2013. This is what I see in the About page:
    [​IMG]
    --- Post Merged, Feb 8, 2016 ---
    I have the feeling this isn't a beta in any shape or form. Perhaps you're looking for the Canary channel?

    https://www.google.com/chrome/browser/canary.html

    I just tried it, and it's a differently named app. The icon is yellow-tinted, and on the About-page, it says "Version 50.0.2644.0 canary (64-bit)".
     
  11. A4orce84, Feb 8, 2016
    Last edited: Feb 8, 2016

    A4orce84 thread starter macrumors regular

    Joined:
    Apr 17, 2012
    #11
    Hey Cerberusss,

    Thank you for testing! That's exactly what I am seeing as well. I really appreciate your help with this!

    Agreed, it looks like the issue is possibly the Beta .dmg file is not really a Beta after all for some reason. I think this is an issue with the actual file to the Beta version of Chrome.

    I actually am looking for the "Beta", it should look like the following (screenshot from my rMBP):
    [​IMG]


    Can anyone else do a sanity check for us? Maybe I need to write to Google's Support about this issue.

    Thanks,
    Asif
     

Share This Page