Calls/texts functions without iPhone (via wifi?)

Discussion in 'Apple Watch' started by ddkkpp, Sep 7, 2015.

  1. ddkkpp macrumors 6502

    ddkkpp

    Joined:
    May 28, 2011
    #1
    I've had an Apple watch (space grey sport) for a couple months now, and whenever I'm out of range of my iphone (pretty often as I hate it in my pocket, 5S btw), i get the little red "no phone" icon and my watch doesn't (seem to) receive texts/phone calls. How can you tell if your watch is connected to wifi or not?

    Someone said earlier that if your phone is connected to a 5ghz network your watch won't work, as it can only connect to 2.4ghz network. That sucks because I can't connect to the 2.4 at work and thats where I leave my phone as I walk around to complete other tasks. (we have two buildings at work, both with wifi, both with 2.4/5ghz networks).

    At home it's much smaller so i'm almost never out of range of the phone, but how can you make sure it's connected to wifi? anyone else having trouble with their watch and wifi?
     
  2. JayLenochiniMac, Sep 7, 2015
    Last edited: Sep 7, 2015

    JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #2
    Disable bluetooth and see if you get notifications via wifi when you're on a known wifi network such as at home.
     
  3. jst1nt macrumors regular

    jst1nt

    Joined:
    Sep 16, 2014
    Location:
    Albany, NY
    #3
    Maybe watchOS2 will help

    WatchConnectivity
    Now you can take advantage of robust device-to-device communication between the WatchKit extension on Apple Watch and the containing app on iPhone. WatchConnectivity enables Apple Watchto communicate with iPhone in new and more efficient ways. WatchConnectivity saves battery life by allowing the WatchKit extension to transfer new information for the iPhone app to use when it’s next launched, allowing for seamless file transfers between the Apple Watch app and iPhone app. Using NSURLSession, Apple Watch can now communicate directly with known wifi hotspots using the new Tetherless Wi-Fi feature in watchOS 2.
     
  4. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #4
    What does this have to do with the basic function of the AW being able to connect to known wifi networks, and it only being able to connect to 2.4 ghz networks?
     
  5. ddkkpp thread starter macrumors 6502

    ddkkpp

    Joined:
    May 28, 2011
    #5
    you mean disable bluetooth on my watch?

    Also, nobody knows if you can check to see what network your watch is connected to when out of range of your phone?
     
  6. Enygmatic macrumors 6502a

    Enygmatic

    Joined:
    Jan 27, 2015
    Location:
    Various
    #6
    Not sure what you mean, but my phone (actually, all of my devices - minus ATV) is connected to my 5Ghz network; my Watch connects to the phone and works fine - obviously on the 2.4Ghz band, as that's all the Watch can use. I figured this was normal - would be awfully short-sighted on Apple's part to force iPhone users to stick to 2.4Ghz for their Watch, when they tout the faster connectivity of their newer devices. Isn't that the point of simultaneous dual bands?
     
  7. CobraPA macrumors 6502

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #7
    You can't check.

    You can disable bluetooth on your phone, so that the watch only has the possibility of using wifi. Wait about 20 seconds and you'll either see the blue no-connect icon or not. That seems to be the best way to tell if the watch is using wifi or not. (Your phone needs to be on the same router for this to work, generally, although a few things can work without the phone. iMessage, for example. Not calls though, which you asked about.)
     
  8. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #8
    About 5/2.4GHz: if your phone is on 5GHz your Watch will automatically try to connect to the same SSID with the same password using 2.4GHz. So as long as your wifi network is broadcasting on both 5GHz and 2.4GHz everything works fine.

    Works great in my house. By looking at my router I can see my phone connected at 5GHz and my Watch is connected at 2.4GHz.
     
  9. Jshwon macrumors 6502

    Jshwon

    Joined:
    Nov 2, 2007
    #9
    I thought I read somewhere that the watch can connect to the phone even if on different wifi networks. For instance I have two wifi networks at home one of upstairs and one for down. I read that if your phone has been on both networks and remembers them then the watch would do the same. So if my phone is downstairs my watch should still work connected to the upstairs network.

    Can anyone confirm this?
     
  10. exxxviii, Sep 8, 2015
    Last edited: Sep 8, 2015

    exxxviii macrumors 65816

    exxxviii

    Joined:
    May 20, 2015
    #10
    This depends on how you are using the term "network." In general, if have one network (in simple terms, one device handing out DHCP IP addresses), with multiple WiFi access points on the same SSID, then the phone and watch will hand off to one another and work fine as you move around between access points. You will want all of the access points configured with the same SSID and passwords and be slaves to the main edge router managing NATing and DHCP.

    If you have multiple routers handing out IP addresses and those routers are also functioning as access points, even if the SSIDs are are the same, then your watch and phone behavior will be unpredictable.

    If you have multiple access points on different SSIDs, then your watch and phone behavior will be unpredictable.
    You root problem is that it looks like your office configured its network to segregate the 5GHz and 2.4GHz WiFi bands for independent functions. Ideally, you would want both WiFi bands on the same network and same SSID so that the phone will make the best band connection decision and then hand the SSID credentials to the phone. But, if the two bands are set to different SSIDs or different networks, and you can only connect to 5GHz, then it renders the watch's WiFi connection inoperative. This should be an atypical network configuration, as 2.4GHz is a much better band all-around for WiFi performance.

    Last, to answer your question about knowing if the watch is connecting, there are two ways. First, just turn off BT on the phone as others have posted, and the phone should still connect. Then, while your phone's BT is off, check your router's client list-- you should see the watch connected to the router.
     
  11. CobraPA macrumors 6502

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #11
    This was not working in WatchOS 1, are you referring to WatchOS 2 betas? Or maybe it is working for some and not for others?

    (At least not the way you describe. If you were able to explicitly connect the phone to the 2.4G network, then the watch would pick up the connection. Several people could not get it to work if the phone was connected to the 5G network.)
     
  12. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #12
    This REALLY DOES work on WatchOS1. Like others have mentioned it would be pretty dumb for Apple to release this product and not have it work with the default way 99% of routers come configured.

    The attached image is from my wifi router _right now_ (just turned BT off on my phone and waited for a moment until the Watch connected to wifi). I'm running WatchOS1 and iOS 8.

    As for why it works for some and not for others... must just be buggy wifi routers (or, more likely a PEBCAC problem ;-)

    Derek

    watch_wifi.png
     
  13. exxxviii macrumors 65816

    exxxviii

    Joined:
    May 20, 2015
    #13
    Ditto to friedmud's post. It would actually be harder to make this not work than to make it work. I would be curious to know the WiFi and network design for the cases where people had trouble-- I suspect a bad network design in those instances.
     
  14. ddkkpp thread starter macrumors 6502

    ddkkpp

    Joined:
    May 28, 2011
    #14
    Thanks for this - bluetooth disabled - no connection - i still get the red "no phone" icon. (it's sitting beside me on my desk)

    haha DAMN; i've always named my 2.4ghz and 5ghz networks differently. They have the same password, but different names - like I wanted to differentiate them or something. Anyways, here at work, I have an apple router, so i just popped open my airport utility and renamed my 2.4 and 5ghz networks to the same name.

    Didn't work. I still get a "no phone" icon - restarted both my phone and my watch. Could it be because i have a 5S? Maybe I need to re-pair the watch?

    That's cool - so it SHOULD work. so frustrating that it doesn't here.


    So I did some more troubleshooting, turned my bluetooth back on after a restart, got the watch connected again. (was funny, when the phone reconnected to the watch the second hand stopped for 3-5 seconds, then jumped suddenly. and slowly my complications started to blink into the screen).

    So after I re-connected by bluetooth (now that my networks are named the same), i disconnected the bluetooth once more and i have the red "no phone" icon up top again. super lame!! (looks like if you have the red "no phone" icon, you don't get texts to your watch.. just sent myself a test).

    Maybe I'll try a re-pair? any other suggestions? Maybe texts still work even with the red "no phone" icon?
     
  15. exxxviii macrumors 65816

    exxxviii

    Joined:
    May 20, 2015
    #15
    Try forgetting and re-adding the network from the iPhone.
     
  16. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #16
    I'll second exxxviii 's idea of removing and re-adding the network on your phone (while it is connected to your watch over BT - that way your Watch can get the new info).

    I would like to address one thing you said though:

    That's actually not true... but you DO need to get your Watch on wifi first. If you do manage to get your Watch to connect over wifi (so it can talk to your phone even with BT off)... then you can actually turn your phone off (or not have it with you in the future) and your Watch will stay connected over wifi and your Watch will still be able to send iMessages, do email and all the other stuff listed here: http://www.redmondpie.com/20-things-apple-watch-can-do-on-wifi-without-iphone-in-bluetooth-range/

    Your Watch will even connect to known Wifi networks on its own... completely independently of the phone if your phone is not around. The device is actually fairly tenacious about staying connected to the internet ;-)
     
  17. ddkkpp thread starter macrumors 6502

    ddkkpp

    Joined:
    May 28, 2011
    #17
    I've made another discovery - you can't name (in airport express anyways) a 2.4 and 5ghz network with the exact same name. they must be different.
     
  18. exxxviii, Sep 8, 2015
    Last edited: Sep 8, 2015

    exxxviii macrumors 65816

    exxxviii

    Joined:
    May 20, 2015
    #18
    That can't be true. That would be moronic. (There are other more accurately descriptive words, but this is a family forum.)
     
  19. CobraPA, Sep 9, 2015
    Last edited: Sep 9, 2015

    CobraPA macrumors 6502

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #19
    They don't need to have the same name, but if not, you would need to access the 2.4G from your iphone, so it can pass the settings to your watch. This is how my home network is setup. Once I used the phone on the 2.4G network and made sure the watch connected, I can take the phone back to the 5G band (on the same router) and they will stay connected without bluetooth.

    I suspect the behavior was improved in 1.01. You will find a number of threads here on MacRumors about the watch not attaching with 2.4G/5G networks with the same SSID. It was suspected that 1.0 did not support watch configuration when the iphone was on the 5G network and the SSIDs matched.
     
  20. Southern Dad macrumors 65816

    Southern Dad

    Joined:
    May 23, 2010
    Location:
    Georgia
    #20
    As previous posters have hit on, the trick is to put your iPhone on the 2.4 network once. Then the watch will go to it without an issue. One day, when I was particularly heavy in my usage, my iPhone ran out of battery and powered down. Since the day was almost over, I wasn't worried about it. Then to my surprise a call came in via my Apple Watch. I looked at it like it was possessed.
     
  21. ddkkpp thread starter macrumors 6502

    ddkkpp

    Joined:
    May 28, 2011
    #21
    it is true though.

    i named my SSID "blahblah" on the 2.4ghz, but when i selected the 5ghz, it automatically appends the "5GHz" at the end of the name.

    If you remove that "5GHz" from the SSID, so that the name is the same as the 2.4GHz one, it allows you to continue, but it does not actually create the network.

    Each time I search for the network, there is only one displayed, and it is the 2.4GHz network. I open the network settings again and the "create 5ghz network" box is unchecked - the software does this without telling you.

    I've tried this, no dice. both at home and at work. I usually just put my phone into airplane mode and send myself a text from my phone provider's website - nothing comes through.

    Now, I use a proxy called Weblock to block all ads, etc, and i thought that might be causing some interference for the watch, so i've disabled weblock and reconnected to my 2.4ghz network, but to no avail. I still don't get texts.

    The last thing I will try is unpairing, forgetting the network, repairing, reconnecting to the network with Weblock disabled. I might just try this next week after OS2 is out though. I think installing OS2 requires a repair anyways?
     
  22. exxxviii macrumors 65816

    exxxviii

    Joined:
    May 20, 2015
    #22
    Wow. Just wow. It is as if Apple just skipped the classes on network architecture. And, it goes against a WiFi tips article written by a person claiming to be a former Apple WiFi network engineer. I wonder if this alleged dude really knew how his former employer's products are made.

    http://www.macobserver.com/tmo/answers/4-wi-fi-tips-from-former-apple-wi-fi-engineer

    I would seriously dump that WiFi router and get one that works properly. You really need both bands on the same SSID to get the best performance. What happens is that 2.4 GHz covers the house better because walls do not attenuate the signal as much. And 5 GHz can give you the fastest speed, but it has signal strength issues. So, the client will pick the best band for its needs based on what it is seeing between the two bands.
     
  23. nicho macrumors 68000

    Joined:
    Feb 15, 2008
    #23
    mine's not here right now to check, i left it at home, but in airport utility for my time capsule... you don't have the option to not create a 5GHz network. you do have the option to *name* the 5GHz network differently, by checking the box, if you wanted an atypical setup with two different SSIDs - ie, one for each spectrum. otherwise, it creates both. if you leave it as default pumping out both, then a mac will only show you the info of the one it gets the best connection from. for example, i see i'm connected to my network on 2.4GHz. I can't see the 5GHz network at all right now, because the computer knows it's the same network but the 2.4GHz connection is better right now.

    what version of airport express do you have? and more importantly, what computer are you using to check this info? i can't see airport utility being so vastly different between time capsule and airport express that it would let you disable the 5GHz network :/
     

Share This Page