Cam is very laggy

Discussion in 'MacBook Air' started by digitalove, Nov 8, 2014.

  1. digitalove macrumors regular

    Joined:
    Jun 12, 2012
    #1
    I bought a new MacBook Air '13 (Early 2014).

    Everything is ok. Except the cam: every time I open the FaceTime app or also Photo Booth the camera lags a lot. The image is really slow to update.

    Is there anything I could do to fix it?
     
  2. John marts macrumors member

    Joined:
    Sep 20, 2014
    #2
    Mine is laggy too. I also get the spinning beach ball when choosing effects in photo booth.
     
  3. capital47 macrumors newbie

    Joined:
    Nov 24, 2014
  4. JUNNEL20 macrumors member

    Joined:
    May 23, 2008
  5. digitalove thread starter macrumors regular

    Joined:
    Jun 12, 2012
    #5
    I didn't.

    1.4 GHz i5
    4 GB
    OS X 10.10.1

    The mac is new, it's the early 2014 model.
    I can't believe the camera lag so badly and also sometimes Safari isn't very fast. You must consider that the mac is new and I didn't install anything on it.. So I'm safe and the mac is new. I can't get why the camera is laggy..
     
  6. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #6
    The macbook specs (especially RAM) are completely irrelevant for this issue. We have a mba 1.3/4/256 and I've recorded and simultaneously monitored 1080p uncompressed video from a professional camera via Black magic Ultrastudio. Nothing lagged.

    ----------

    That is really inacceptable and this is what I recommend:

    • Reset pram
    • Repair disk permissions
    • Make a timemachine backup
    • Reboot into recovery to reinstall the OS
    • Test the camera right after the installation without other apps installed

    If it still lags take it to the :apple:store and they have to do a hardware check and give you a replacement.
     
  7. digitalove thread starter macrumors regular

    Joined:
    Jun 12, 2012
    #7
    Well I have reinstalled OS and now the camera works :) !

    To be honest it's pretty weird that I had to reinstall the OS X since this Air isn't even 1 month old. But yeah now the camera works and I feel the mac is faster than before.

    Btw I'm not sure if I did format on the right way: at first I reboot and then I went to the utility panel. I did erase both things (2 partition) so I had to reinstall first Mavericks and then - once I reinstalled Mavericks - I had to reinstall Yosemite again.

    https://www.dropbox.com/s/3abm7x6igx34jap/Screenshot 2014-12-03 12.50.36.png?dl=0

    https://www.dropbox.com/s/5bzyoo33wdxclz5/Screenshot 2014-12-03 12.50.38.png?dl=0

    I don't know why it says that I used 120 gb. Maybe Mavericks is still there? How can I delete it?

    I didn't install any 3rd part apps, not even from the mac app store except Dropbox/Adobe. (I don't have more than 3-4 gb of stuff on Dropbox)
     
  8. digitalove thread starter macrumors regular

    Joined:
    Jun 12, 2012
    #8
    Edit: I was browsing youporn and then the mackeeeper page opened itself (I didn't open/download anything)
    Guess what? After that the camera is lagging again, ****.
     
  9. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #9
    I told you so. Remember that 99% of all problems are software related.
    If you write that your cam is laggy and someone is actually equating that to "not enough RAM" then you know that they have to be full of it.

    ----------

    Stay away from porn!
    If you somehow can't restrain yourself, watch it on an iPad, since iPads can't get malware.
     
  10. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #10
    I doubt it's related. I'm not aware of any Mac malware you can get simply by seeing a web site popup.

    It sounds like you have a problem but clearly nobody knows what it is or what's causing it. Sorry.

    What software are you using to test camera performance? Maybe reboot your Mac and don't run any software other than FaceTime to see how well it's working?
     
  11. digitalove thread starter macrumors regular

    Joined:
    Jun 12, 2012
    #11
    I tried everything on your list but the problem is still here.
    I guess I'll take it to the apple store.. even if I will see because I need it so it's a mess. I didn't expect at all to have some issues with a new MacBook, really surprised..
     
  12. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #12
    It's the right thing to do. It shouldn't act like you described.
     
  13. capital47 macrumors newbie

    Joined:
    Nov 24, 2014
    #13
    I had this laggy camera problem when i opened Chatreoullete.com with Safari, my solution was to simply restart my mac and use Chrome. No problem with Google Chrome what so ever. Lots of problems with that Safari tho. I had also some service that would take a LOT of ram for unknown reason. I stopped using Safari for good until they fix it...
     
  14. marshallbedsaul macrumors 6502a

    marshallbedsaul

    Joined:
    Nov 14, 2007
    Location:
    Maryland
    #14
    my Photo Booth is laggy as well (13 inch Amba 2014) rather annoying but w.e
     

Share This Page