Camera and Pictures Broken iOS 6 please help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by vree, Mar 8, 2013.

  1. vree, Mar 8, 2013
    Last edited: Mar 8, 2013

    vree macrumors member

    Mar 8, 2013
    Hi everyone,

    So I updated to the new ios6 and had like 5 days work getting everything back like it used to be.
    Ios 6.1.2

    But for the final touch I wanted to use Iexplorer to put my old photo's back in the photo roll. And then everything went wrong :S

    I deleted the following folder:
    Made a new one with the same name and putted all my old pictures in it.

    Then I went to:
    And deleted the files I had to but I think I deleted something I didn't backup or backed up wrong.

    After messing around some of the following things happend(after deleting and retrying):
    -Picture/photos app and camera app don't launch
    -Picture/photos app launches with old pictures but new camera app pictures don't appear in them.
    -I see 4 old random pictures and nothing else
    -and so on.

    So does anyone know how to fix this. I really can't afford to do a restore and lose days of work :S.

    Maybe someone could upload a backup of thei PhotoData and that could fix it? Or tell me wich files to delete and try again???

    Please I'm desperate. I really don't know what went wrong because I have done this before on the older Ios versions.

    All help is really appreciated.
  2. vree thread starter macrumors member

    Mar 8, 2013
    Ok just solved my own issue and wanted to share it here:

    What does it fix?:
    -Camera app and Picture/photos app crashing.
    -Thumbnails being black not showing
    -Not all pictures being shown.
    -Camera pictures taken not showing up in the album.

    To begin:
    1. Close the camera and picture/photos app by fast pressing the home button 2 times and shutting them down there.
    2. Put all your old pictures in "/private/var/mobile/Media/DCIM/100APPLE"
    OR delete every picture in there to have a clean start.

    1. Go to "private/var/mobile/Media/PhotoData/" and delete every file (NO FOLDERS! just the files) from that directory
    2. Delete "DCIM_APPLE.plist" from "private/var/mobile/Media/PhotoData/MISC/"
    3. Delete everything in "private/var/mobile/Media/PhotoData/Thumbnails"

    To end:
    1. Disconnect you iphone from your PC and reboot it.
    2. Take a random screenshot of your display by pressing power and home button at the same time.
    3. Open the picture/photos app and wait. Then open the album folder and wait again.
    After a while it should restore all your pictures from "/private/var/mobile/Media/DCIM/100APPLE"

    Now you should be finished and everything should work fine again.
    I hope this will help some people out there.

Share This Page