Camera App On iPhone 4 Doesn't Work

Discussion in 'iPhone' started by irDigital0l, Nov 8, 2011.

  1. irDigital0l Guest

    Joined:
    Dec 7, 2010
    #1
    For some reason my camera and photo app doesn't work on my verizon iPhone 4. I tried to take a picture today and the camera app just crashes. Same with the photo app, I tried to delete some photots but they wouldn't delete.

    Also, Camera+ seems to take photos just fine, its just the original camera and photo app. I tried powering off my device and turning it back on but no luck.

    Really weird how it was working fine since Feb when I bought the phone...

    If it helps I'mm on iOS5 with a non jb phone.
     
  2. irDigital0l thread starter Guest

    Joined:
    Dec 7, 2010
  3. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
  4. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #4
    Try killing the camera app - double-click home button to bring up the recent apps, press/hold camera app until it starts wiggling, tap X to shut it down.
     
  5. irDigital0l thread starter Guest

    Joined:
    Dec 7, 2010
    #5
    First thing I tried, and it didn't work.

    Restoring it now...

    Just if I restore it and it doesn't work, should I take it to an Apple Store? And if I bought my iPhone 4 this year in Feb, do I still get warranty? Assuming its a bigger problem than a small glitch or something...
     
  6. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #6
    There is a 1 year warranty so you should be good. I would schedule an appointment at your local Apple store and make sure your phone is having the issue before you bring it in so you can show them. I had an issue with my iPad 2 and they were really good with replacing mine.
     
  7. irDigital0l thread starter Guest

    Joined:
    Dec 7, 2010
    #7
    Just finished restoring/back up from iClouds and camera still is having issues.

    It just crashes whenever I press the button to take a pic.
     

Share This Page