Camera loading in iPhoto, not devices

Discussion in 'Mac Basics and Help' started by murderline, Sep 12, 2008.

  1. murderline macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    Hi- I've looked through threads trying to find a similar issue, but no one appears to have the same problem.

    I have tried plugging my camera into two macs- 10.3.9 and 10.5.2 and both of them do not show the camera under devices or on the desktop. I tried to change the settings on image capture of automatically opening iPhoto when the camera was plugged in and then when I plugged the camera in again nothing happened.

    I've been able to open the camera through devices previously on 10.3.9 before I started using 10.5.2 but now it only opens iPhoto...

    Sorry to be annoying, it's just that some photos got deleted and the programs to undelete the images require you to select the camera from devices. Thanks in advance.
     
  2. ftaok macrumors 603

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #2
    Do you have access to a card reader? That might work. Many photo printers have card slots ... but even if you don't have a reader, it won't cost too much to get one.

    I'd try that route first, or maybe a different "undelete" utility.
     
  3. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #3
    First, you're not annoying, this an interesting one. One of the regular standard responses is to repair Permissions (I recommend Onyx for that job). If that repairs what I think is a Finder issue, try again to mount the camera to the Desktop.

    If not, you could try deleting the Finder prefs User > Library > Preferences com.apple.finder.plist and then rebooting. You'll need to restore a few settings.

    A suggestion: Quit iPhoto each time it opens upon mounting the camera, and just use Finder to manage your pics. [I find iPhoto a bit of a pain when it tries to take over my photo work.]

    Failing all of the above, the suggestion of a camera card reader might just work.
     
  4. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #4
    What brand of camera? My undertsanding is that Canons do not mount as devices (and that is borne out by my own experience -- I have two Canons and neither mount).
     

Share This Page