Camera Not Connecting To Mac?

Discussion in 'Mac Accessories' started by Goftrey, Nov 29, 2011.

  1. Goftrey macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Location:
    Wales, UK
    #1
    I have a samsung st65 digital camera (nice camera too ;) )

    Anyway, when you plug it into a PC normally, you turn the camera on and plug it in, the computer automatically finds it, when I plug it in to my emac though... There's two options, one connect to computer and two connect to printer, obviously I click connect to computer. Then it just says 'connecting to computer' for About 30 seconds it goes back to the display I was at before.

    My emac has USB 1.1 and the camera is drag 'n' drop, incase that helps..

    Please help guys, I've been plugging the camera into my laptop, the transferring them to a USB Stick, the. Putting them onto my emac to edit them... But I've sold the laptop now so I'm in a bit of a sticky situation..
     
  2. Badrottie Suspended

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #2
    EXCUSE ME? You SOLD your PB again????
     
  3. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #3
    Have you considered getting a USB card reader?
     
  4. Goftrey thread starter macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Location:
    Wales, UK
    #4
    No :D

    I have an eMac as well! Haha, I sold my Windows laptop, remember? :p

    ----------

    I think I've decided now to get a PCMCIA USB 2.0 card for my PowerBook instead... But I had thought about that before... Thanks for the response man :)
     

Share This Page