Camera not saving pictures after upgrading to iOS 5 (iP 4)

Discussion in 'iOS 5 and earlier' started by alexwgreen, Oct 19, 2011.

  1. alexwgreen macrumors newbie

    Jun 8, 2011
    Hey guys,

    I did a quick search but couldn't find anything similar.

    Since installing iOS 5 to my iPhone 4, my camera has stopped working properly. Now, when I take a photo I get the usual click, followed by the photo flying down to the little camera roll preview/icon at bottom left, which then goes black. When opening PHOTOS, I briefly get the normal display, which then crashes back to home page.

    My photos also appear to have disappeared, though this isn't a real issue for me. Relatively new phone and no photos of merit or sentimental value as yet.

    So far, I have tried switching off and on, hard reset, toggling photostream on/off in settings. The latter also causes settings to crash back to the home page.

    Can anyone advise. I'm reluctant to restore to factory settings and restore.

    Any suggestions. This is driving me up the wall.


  2. RyanShipp macrumors newbie

    Oct 24, 2011
    Same here...


    I seem to be having the exact issue you describe. Have you found a resolution, or have you tried restoring yet?

  3. mekkon macrumors newbie

    May 6, 2004
    Ditto with me. After I upgraded my iPhone 4 to iOS5, the photos seem to save only occasionally. Sometimes the camera works and saves photos as expected, other times the photos simply aren't there in the library when I try to look at them later in the day. They're gone forever, as though they'd never been taken.

    For me it seems to happen considerably more often when I'm using the special Lock Screen -> Camera feature. When I shoot a photo that way it often won't be saved anywhere, which is frustrating, since those are the quick shots that can be the most interesting.
  4. RyanShipp macrumors newbie

    Oct 24, 2011

    I did a bIt more reading and decided to go ahead and restore to factory settings. It seems to have fixed the issue I was having with the camera not storing photos and video to the camera roll. Now to set everything back up again :(
  5. kirky29 macrumors 65816


    Jun 17, 2009
    Lincolnshire, England
    I had an issue very similar, I'd been a dev using iOS 5 since around July!
    Everything has just been perfect, I've taken 1000's of pictures this month, then last night taking a picture, it crashed and reloaded the springboard, since that, each picture I take comes out blurry, and file size 0KB. Couldn't even view them on Mac/PC.
    So I emailed a few pics to myself, and they were fine...
    Managed to save several hundred via an App sending them directly to my desktop.

    Then I deleted all my pics manually (takes time, there should be a select all pics button) - but still it didn't work, they came out blurry, or some just came out black. - I had this problem happen on my old 3G running iOS 3 (I think).

    So, I plugged into iTunes, reinstalled iOS 5 and just run the backup from iCloud and then all my pictures magically came back (except the bad, corrupt ones) and it seems to be working fine again now.

    I use the option to save both the original and the HDR version, and it crashed when trying to save a HDR version when I quickly moved the phone...Might have been just a coincidence. But it seems when there is a corrupt picture, they all go crazy.
  6. thepopnick macrumors newbie

    Oct 15, 2011
    I'm in the middle of a factory settings restore because I shot a 45 minute vid on my 4s -- that just... disappeared the minute I hit stop. What's crazy is that when I go into the "manage storage" section of my settings, it says that my camera roll accounts for 8.5 gigs of hd space. Since I only have like, 20 photos, obviously the vid is IN there somewhere. It just won't let me access it. I've tried the photo app, the camera app (using it to view photos), the videos app, itunes... nothing. No indication that it exists, except for the space it occupies.

    I've tried to hook it up to my macbook and import the video manually, but it doesn't see it there either. This is a strange glitch with ios5/icloud. Any thoughts?
  7. skilz00 macrumors newbie

    Feb 25, 2012
    I'm having trouble with saving pics and vids from the lock screen camera shortcut as well. It's always empty and it says my iPhone is locked and I have to unlock it to see the pictures. I do not have a password set and the pictures I "took" in the LS camera don't show up in the photos app either.
  8. sdtbftone1 macrumors newbie

    May 18, 2007
    North Carolina
    Same problem here


Share This Page