Camera not working

Discussion in 'MacBook Air' started by ClashCR77, Sep 14, 2012.

  1. ClashCR77 macrumors newbie

    Sep 14, 2012
    Hi, I got a macbook air 13" today. Unfortunately, the facetime camera doesn't work. I called Apple support and they said to go to the store and replace it. It's a long drive, so I was hoping you all might have a last minute fix before I go. Thanks!
  2. asting macrumors 6502

    Jun 10, 2012
    I had an issue with this so I can try and walk you through the steps to see if it's hardware.

    1. go to apple-> about this mac-> more info->System report->USB. See if the facetime HD camera is listed there. If not, then proceed. If so, it sounds like a software issue.

    2. See if there are any firmware updates through the apple software center. If so, install them, then check again.
    If that doesn't work
    3. Reset the SMC:
    If that doesn't work
    4. Reset the pram:
    If that doesn't work
    5. Reflash SMC:

    If all that fails, it sounds like a hardware issue.

    Report back with results.
  3. ClashCR77 thread starter macrumors newbie

    Sep 14, 2012

    Thanks man, I tried all those things but it didnt help.. my camera was listed in the system profiler
  4. asting macrumors 6502

    Jun 10, 2012
    Sorry I managed to miss your reply. If it is listed in the system profiler, then perhaps reinstalling os x would have helped. It is of course still possible that it functions enough to be detected but doesn't actually work. At any rate, I'm sure they swapped it out for ya.
  5. brbubba macrumors 6502


    May 20, 2006
    Been having this problem since i bought my 11" Air over the summer. Same exact thing, shows in system profiler, restart fixes it temporarily and then it zonks out again after prolonged sleep. It worked for a bit during one of the system updates, but is dead again.

    Just brought it into apple store finally to beat the rush after Xmas. So far they can sort of replicate it, but nothing definite. They're going to reinstall Mountain Lion from scratch and see if that helps. I did try this in the past, but it was Lion and then immediately upgraded to Mountain Lion. So I'm somewhat hopeful, but not really.

Share This Page