Camera Roll bug iOS 4

Discussion in 'iPhone' started by AHDuke99, Jun 21, 2010.

  1. AHDuke99 macrumors 68020

    AHDuke99

    Joined:
    Nov 14, 2002
    Location:
    Charleston, SC
    #1
    Anyone have a black block when they click on their camera roll? I can still view my photos if I tap one of them, but when I back out, instead of seeing thumbnails, I see just blackness. Is this a bug or what? I tried restoring twice from my backup to no avail.
     
  2. HelveticaNeue macrumors 6502a

    HelveticaNeue

    Joined:
    Apr 24, 2010
    #2
    I have notice a bug similar to what you are saying in iOS 4. If I import all my photos in iPhoto and tell it to delete them on the phone. The next time I open the photo app on my phone it shows me one of the photos that should have just been deleted. Also, when I return to the gallery, there are black boxes where all the photos I just imported were. This bug happens because of the multitasking now in the app, which remembers where I last left off in he photo app and tries to display photos that have been deleted. To correct this, i have to double click the home button and quit the photo app.

    I have reported this bug to :apple:

    Also, i hate that photos are no longer named sequentially. It used to be that if I imported 200 photos and deleted them the iPhone remembered that i had previously taken 200 pics and named the next one 201. Now after I import, my photos start at img0001 again. Which is annoying because when I drag them into folders on my computer i have to manually rename them since two pics can't exit with the same name.
     
  3. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #3
    After my initial restore I could not view any photos if I went in through the Photos app. However, I could see them if I went in through the Camera app. I powered down and restarted the phone and haven't had the problem since.
     
  4. guitardave62000 macrumors regular

    Joined:
    Oct 2, 2008
    #4
    i have the same problem right now with my iphone 4 its really frustrating, hopefully a software fix is on the way to fix this
     
  5. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #5
    The only Camera Roll bug that I've seen so far is one that prevents me from switching from portrait to landscape mode when rotating the phone. If I double tap the home button and kill the Photos app from the tray and then re-open it, the problem goes away.
     
  6. Razorhog macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #6
    I'm experiencing some camera roll bugs. Black boxes, single shots showing up 4 times, photos showing up when accessed via the camera but not when accessed via photos until I reboot the phone, etc.
     
  7. csmitty macrumors regular

    Joined:
    Sep 15, 2007
    #7
    I get the black boxes as well after I import to iphoto and then delete. Exiting out and then back in usually fixes it. Or if there are no photos just taking a shot and deleting works. I'm sure it'll be a fix soon since its a pretty pronounced bug.
     
  8. TheGink macrumors newbie

    Joined:
    Jan 2, 2010
    #8
    I just got this bug for the first time with my iPhone 4 when I updated to iOS 4.1, my camera roll is now a black box, new photos show up fine, but no amount of closing the photos or camera app from the multitasker, or rebooting the phone seem to effect it. It's a somewhat minor bug, but pretty annoying.
     
  9. malnar macrumors 6502a

    malnar

    Joined:
    Aug 20, 2008
    #9
    What?! I haven't done that yet but . . . ! That is ridiculous. Did you report this too? That has to be bug.

    For the record, I have a similar issue to the OP: if I delete an image within the photos app, it shows in there as a black block. I deleted hundreds of legacy 3G images out of my photo album when I upgraded and it left a huge amount of these. The only way I could get rid of them was by rebooting the Iphone. Also, new pictures don't show up unless I back out all the way out of albums, then go back in again.
     
  10. Loves2spoon macrumors 65816

    Loves2spoon

    Joined:
    Jun 3, 2010
    Location:
    California
    #10
    This happened to me after trying to delete 4 photos at once. Black boxes appeared.

    Reboot phone, recheck black boxes to delete. all gone.
     
  11. organik12 macrumors newbie

    Joined:
    Feb 19, 2008
    #11
    I just got the black block after updating to 4.0.1
    it only seems to cover the past 20 or so pics taken. and does not go away after rebooting, or restarting camera roll:apple::mad:
     
  12. fsck-y dingo macrumors 65816

    fsck-y dingo

    Joined:
    Jun 14, 2009
    #12
    I'm not sure if this is what's happening to you but when you sync new photos while the photo app is still in the multitask dock it doesn't display the thumbnails. Instead you get the black thumbnails as you describe. Deleting it from the dock and re-opening the app fixes that little problem.
     
  13. bclizzle macrumors 6502

    Joined:
    Apr 29, 2009
    #13
    yeah, my friend and i are having this problem. he updated to 4.0.1 and now he is having it. i havent updated yet but ive had it since day 1.
     
  14. houdinize macrumors regular

    Joined:
    Mar 1, 2008
    #14
    camera bug

    Not the same bug, but, I returned my first iP4 after the camera would not work (hardware problem) then with the second phone the camera stopped working after a day, I rebooted, it fixed it, then worked intermittently for awhile, needing reboots often. Now the camera seems to be fine. Anyone have this along with the camera roll bug?
     

Share This Page