Camera roll photos won't delete

Discussion in 'iPhone' started by spiderguy84, Jun 25, 2010.

  1. spiderguy84 macrumors regular

    Joined:
    Nov 12, 2009
    #1
    I have tried to delete photos in my camera roll and it just turns the thumbnails black and still shows just a black square
     
  2. tfm20 macrumors newbie

    Joined:
    Feb 23, 2010
    #2
    I'm having the same problem on my iPhone 4, really strange.

    Anyone got any ideas?
     
  3. Etnies419 macrumors 6502

    Joined:
    Sep 9, 2008
    #3
    I had this issue after deleting some pictures with iPhoto after transferring them. I just took another photo, and the black boxes went away.
     
  4. Ptyger macrumors member

    Ptyger

    Joined:
    Nov 20, 2008
    Location:
    Knoxville, TN
    #4
    It also helps to completely quit out of the photos and camera apps then restart them. At least that worked for me.
     
  5. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #5
    I had this problem when I was jailbroken, and try to set my phone up as a new phone but copied all the image files back into my image roll directory. Turns out they had the wrong file permissions on them, and couldn't be deleted by the app.

    But if you are on an iPhone 4 then you aren't jailbroken.
     
  6. HelveticaNeue macrumors 6502a

    HelveticaNeue

    Joined:
    Apr 24, 2010
    #6
    I get this after importing to iPhoto too. I have to either quit the photo app in the multitasking bar, or just bring the photo app all the way back to albums.
     
  7. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #7
    Just as an FYI-this worked for me PERFECTLY. Thanks for sharing :D
     
  8. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #8
    I think it's a common bug. I had it happen all the time right after launch day and then didn't see it again for a month, until yesterday. Usually going out of the camera roll and then back in seems to do the trick.
     
  9. w3iiipu macrumors member

    Joined:
    Jun 30, 2010
    #9
    had the same thing happened to me. Took some photos, deleted them and was left with black squares instead. It disappear after i restart the phone.
    Happened twice so far.

    Tried recreating it but no luck.

    edit: i dont use iphoto or anything. I was just taking pictures and deleting it when it happened.
     
  10. MaskedCarrot macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Northern VA
    #10
    Just restart your phone.

    I had that issue when i deleted my camera roll from windows explorer when I had it plugged into my computer. I just restarted my phone and it was clear then.
     

Share This Page