iPhone Camera stopped working after iOS 6 upgrade

Neopilot

macrumors newbie
Original poster
Sep 23, 2012
2
0
Tokyo
I just upgraded to iOS 6 on my iPhone 4 and my camera has stopped working. The camera worked perfectly with iOS 5, but now when I open the camera app the shutter remains closed and never opens. I can change the slider from camera to video and back, yet still the shutter remains closed. I can view my photo library from within the app and even return to the camera app, yet no change in the shutter. No luck switching to the front facing camera either; still just a blank screen. All other apps that use the camera also no longer function. I have performed at least three restores with my most recent one as a "restore as new" vice from backup; still no luck. I called apple care and they tell me they have heard of this from a few individuals, but it "is a hardware-related defect that has manifested itself during the upgrade" and since my iPhone 4 is out of warranty there is "nothing they can do for me". While I am not an apple engineer, I find the theory of a software upgrade triggering a hardware defect EXTREMELY hard to believe. All other features function as advertised as far as I can tell with the phone. Anyone have any suggestions?
 

Wilson1313

macrumors member
Nov 29, 2008
95
169
I would try doing a hard reset and if that doesn't work try connecting to iTunes and restoring the iPhone as new phone.
 

pdqgp

macrumors 68020
Mar 23, 2010
2,130
5,432
I would try doing a hard reset and if that doesn't work try connecting to iTunes and restoring the iPhone as new phone.
^^ this. when in doubt, reboot just like desktops. If not, I too would do a complete restore as new then update and restore the contents.
 

Neopilot

macrumors newbie
Original poster
Sep 23, 2012
2
0
Tokyo
I have tried multiple hard reboots as well as restores "as new iPhone". The phone is an unlocked iPhone 4 bought directly from Apple and never jail broken.
 

max5peru

macrumors member
Sep 18, 2012
62
0
Peru
same problem on an iphone 4S 32GB

Got the same problem after iOS 6.0 update. I have an unlocked iPhone 4S since April, never jailbroken. After the OAT the camera didnt work anymore. I have tried the beta without issues but got some since I upgraded with the GM first (memory issues and over heating phone in the back), then I return to iOS 5.1 without no issues and the camera one appeared after the OTA "official" upgrade.
I made a downgrade to iOS 5.1, hard reset, set phone as new, etc and the back camera never worked again.
I read that there are some HW issues too so I called Apple and they will be waiting for my phone to replace it (I hope)