Can 4.3.5 be jailbroken & unlocked?

Discussion in 'Jailbreaks and iOS Hacks' started by Kauai, Jul 29, 2011.

  1. Kauai macrumors 6502a

    Joined:
    Oct 13, 2010
    #1
    My gut says no, but sadly since I want to sell my iPhone soon I wanted to unlock it so as to maximize profitability. I restored the phone and was not aware that a restore would update it to the latest firmware (I specifically intended to stick with 4.3.3) but now that I'm updated I figure I might as well ask...will PWNage Tools and ultrasnow work for 4.3.5?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    No.
    It can be tethered JB but not unlocked.
    Mind as well sell it as is on stock 4.3.5 locked to AT&T.
     
  3. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #3
    FYI 4.3.3 wasn't unlockable either! ;) you should have stuff with Pwnage at least since 4.0.1. just a little late! this year it might be worth selling the 4g for what you can sell it for. then buy a factory unlocked 4S or I5 what ever it gets called from apple direct. I have a strong feeling that they will be tough to buy when the new model is 1st released.
     
  4. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #4
    I you were jailbroken before, you might have SHSH saved in cydia, and therefore backed up and able to downgrade back to 4.3.3.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    He still won't be able to unlock though.
     
  6. audiman macrumors newbie

    Joined:
    Jul 30, 2011
    #6
    I have a 3gs running 4.2.1 and want to upgrade it. It has baseband 5.13.04

    I know this is unlockable. I want to upgrade it to latest version of iOS that can be unlocked. I know 4.3.3 is unlockable. but want to confirm 4.3.4 or 4.3.5 is? From this thread its saying 4.3.5 is not. Just want to confirm.

    Would it be best to keep it at 4.3.3?
     
  7. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #7
    Whether a phone is software unlockable is based on the baseband and nothing to do with the firmware. While, the firmware version decides if the phone is Jailbreakable or not.

    Thus, if you keep the 5.13 baseband when updating the firmware, it will still be software unlockable with Ultrasnow.

    As for JB, 4.3.3 firmware is a non tethered while 4.3.4 / 4.3.5 are tethered.
     
  8. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #8
    Use pwnagetool and make a custom firmware on 4.3.3, which will preserve your unlockable baseband. It will also jailbreak for you. Once that is installed, use ultrasn0w to unlock.
     
  9. B777Forevar macrumors 6502a

    B777Forevar

    Joined:
    Jul 25, 2011
    Location:
    Chicago, IL
  10. hom.tanks macrumors newbie

    Joined:
    Jul 30, 2011
    #10
    I'm in a similar situation ... mistakenly upgraded iPhone 4 (ATT) to 4.3.4 and now having to unlock it for another carrier. The baseband is 4.10.01

    So from what I understand based on the posts above:

    * jailbreak has to do with the firmware. 4.3.4 means tethered jailbreak only. I WILL be able to JB this phone
    * unlock has to do with baseband. I WILL be therefore be able to unlock this phone once I jailbreak it
    * I can use pwngetool to jailbreak and ultrasn0w to unlock


    Am I correct in this understandings?

    Another question:Is it possible to downgrade to version 4.3.3 ? How? If I do, does that mean that I'll be able to have a unlocked, untethered JB iphone 4 then?

    Sorry if I misunderstood the replies and thanks in advance for your clarifications.

    br,
    HT
     
  11. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #11
    no you can not downgrade unless you have shsh blobs saved. If you son't know what shsh blobs are you don't have them. ;)

    jailbreak is firmware related 4..3.3 below you can do a full jailbreak 4.3.4 and 4.3.5 are tethered only.

    unlock is baseband related to the baseband 1.59 and required Pwnage tools or Sn0wbreeze to keep it. on your iphone you can look at setting/general/about to double check. Ultrasn0w will only work on 1.59 anything else will crash the device.

    you can try the Grevey sim but that will not support anything after 5.0 beta 2.
     
  12. audiman macrumors newbie

    Joined:
    Jul 30, 2011
    #12
    I totally Understand now.

    4.3.3 is untethered and unlockable if kept at 1.59 baseband for iPhone4. and have Shsh files saved.

    What I didnt realize is your cydia automatically stores the shsh's for what ever version that is current when you open cydia. For example currently 4.3.5 is out, so if you open cydia it will automatically store your shsh's for 4.3.5 on their servers, then you can install tiny umbrella to download those to your computer to use to restore down the road.

    Also I didnt realize that if you dont open cydia for a period of time before the next version of ios is released such as if 4.3.6 would come out (which it probably wont but just using as example) and didnt have those 4.3.5 shsh's stored, you cannot retrieve those 4.3.5 shsh's.

    For example on my wife's 3gs I didnt open cydia when 4.3.3 was out, so it never saved those shsh's on cydia so now its not showing them available. :(
    so when i was trying to restore to custom 4.3.3 it kept giving me this error "the iphone could not be restored. this device isnt eligible for the requested" build. I couldnt figure it out until I realized its because I didnt have the 4.3.3 shsh's saved. I had to restore it back to 4.2.1 I could go to 4.3 those are stored. I might do that when I go to sell the phone here in about a month as jailbroken and unlocked.

    At least that is how I'm understanding it. Hope that all makes sense.
     
  13. hom.tanks, Jul 30, 2011
    Last edited: Jul 31, 2011

    hom.tanks macrumors newbie

    Joined:
    Jul 30, 2011
    #13
    Thanks everyone for your pointers and feedback. I do understand things a bit better now (though not everything i admit). So the bottomline for me it seems is that the only alternative I have right now is Gevey provided I can live w/o 5.0 when it comes out.

    One question: how reliable is Gevey esp for use internationally?

    http://www.redmondpie.com/unlock-ios-4.3.4-on-iphone-4-with-gevey-sim/
     

Share This Page