iPod Can anybody help with this?

sunfast

macrumors 68020
Original poster
Oct 14, 2005
2,105
0
London
For some reason, iTunes is screwing up the order of some of my songs (see attached image)

When I played the album marked, some of the tunes took on a new order even though they are clearly marked with numbers and the display was sorted by album. Can anybody help me with this - it's dead annoying!
 

Attachments


cbetta

macrumors regular
Jul 5, 2006
103
0
check what "CD" itunes thinks those songs are on. that probably doesnt match
 

cbetta

macrumors regular
Jul 5, 2006
103
0
as you can see he is already in the album bview, and all songs are in the same album, so I bet you it is the fact that they are in the wrong CD of the album
 

sunfast

macrumors 68020
Original poster
Oct 14, 2005
2,105
0
London
Mitthrawnuruodo said:
Try marking all of the songs of the album, open the info window and type in the album name again...
This was the first thing I tried. And sadly it didn't work. :(

And also, this CD was fine under iTunes 6. Maybe it's a bug.
 

cbetta

macrumors regular
Jul 5, 2006
103
0
just select them all, hit command+I, then set them all to disc 1 of 1, and see if that works.
 

Mitthrawnuruodo

Moderator emeritus
Mar 10, 2004
13,792
147
Bergen, Norway
cbetta said:
as you can see he is already in the album bview, and all songs are in the same album, so I bet you it is the fact that they are in the wrong CD of the album
I know, but I've encountered a couple of times where seemingly identical album titles can cause this... it might be completely subtle differences like the difference between a normal space and a shift-space, or something...

...but I agree, Disc Number might be a very likely culprit, too... ;)
 

Verschoren

macrumors regular
Apr 1, 2005
176
0
Antwerp, Belgium
check album artist..

i had the same problem with many (MANY) songs, and most of them we're fixed with setting the album artist to the same name as the artist (or just clearing the info in album artist.)
 

sunfast

macrumors 68020
Original poster
Oct 14, 2005
2,105
0
London
Thanks for the advice chaps.

As you can see from the attached image the artist, album and cd are the same for all tracks. A bug?
 

Attachments

Mitthrawnuruodo

Moderator emeritus
Mar 10, 2004
13,792
147
Bergen, Norway
sunfast said:
Thanks for the advice chaps.

As you can see from the attached image the artist, album and cd are the same for all tracks. A bug?
Maybe... but have some of the songs a different Album Artist, like Thomas421 suggested...? That is not possible to see from your attachment... :)
 

sunfast

macrumors 68020
Original poster
Oct 14, 2005
2,105
0
London
Mitthrawnuruodo said:
Maybe... but have some of the songs a different Album Artist, like Thomas421 suggested...? That is not possible to see from your attachment... :)
Ah - I understand what Thomas421 meant now. Will try that when I get home this evening.

Thanks again for all the help everybody. :)
 

sunfast

macrumors 68020
Original poster
Oct 14, 2005
2,105
0
London
Thomas421 said:
check album artist..

i had the same problem with many (MANY) songs, and most of them we're fixed with setting the album artist to the same name as the artist (or just clearing the info in album artist.)
Spot on. This has fixed the problem!

Thank you very much! :)