Can anyone help with battery image/Cydia question?

Discussion in 'Jailbreaks and iOS Hacks' started by smdphoto, Jul 22, 2008.

  1. smdphoto macrumors newbie

    Joined:
    Sep 6, 2007
    #1
    Hi there,

    I used Cydia to install a battery image on my iP3G, then decided I didnt like it. I uninstalled it and now I have no battery image at all when charging (I am speaking of the large one on the main screen). Anyway, when trying to install any other battery images from Cydia, I always get this error.

    Can anyone shed any light on this?

    Thanks,

    Sam D.
     

    Attached Files:

  2. donPedro macrumors newbie

    Joined:
    Dec 21, 2007
    #2
    Ditto

    Hey, I have the exact same issue (on an original iPhone)... I even tried to re-install the same battery mod, and it had the same error! It's sort of frustrating, and I'd like to see some sort of resolution to this issue that doesn't involve restoring!

    Can anyone help?
     
  3. donPedro macrumors newbie

    Joined:
    Dec 21, 2007
    #3
    Quick fix

    So, I found this on another site... what happens is the "charging battery" png images get deleted when you remove any of the battery mods. Seems like a huge bug that should be fixed. The quick fix is to put the necessary files back on your phone, then run Cydia and add the battery mod you want.

    You need to get the original battery charging images, or just make up some dummy files that will take their place temporarily. They are called "BatteryBG_1.png-BatteryBG_17.png" (17 of them, total). After you have them, originals or not...

    1. Go to the battery background directory:
    /System/Library/CoreServices/SpringBoard.app/
    2. Add the 17 missing files BatteryBG_1.png-BatteryBG_17.png to that directory
    3. Run Cydia and find a battery mod (if you had dummy files)
    4. Restart - everything should be fine

    Now remember, if you use the Cydia battery mods, DON'T uninstall them... it will delete the files off of your iPhone and not restore the previous versions (as it should have done, in my opinion).

    Hope that helps
     
  4. cuzz501 macrumors newbie

    Joined:
    Sep 10, 2010
    #4
    I have all of the files that are needed in the directory and I still have no battery when I'm charging. can you think of anything else that may be causing this?
     
  5. cuzz501 macrumors newbie

    Joined:
    Sep 10, 2010
    #5
    also I haven't gotten any error messages. I've changed the files in /System/Library/CoreServices/SpringBoard.app/
    Created a new battery folder com.apple.springbord in themes and nothing is working, it doesn't even make the chime sound when I connect my phone to a power source.
    :mad: this is very frustrating.
     

Share This Page