Can anyone send me an older version of Pages for Mac?

Discussion in 'Mac Apps and Mac App Store' started by Jardins de Vin, Mar 7, 2016.

  1. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #1
    Eventually you've read my thread about Pages not working on my iPad anymore. Anyway, here's the problem:

    • iPad is on iOS 8.3, latest possible version of Pages installed on it.

    • Updated Pages on Mac, since then I can't open documents modified or created on Mac on my iPad anymore

    • Don't want to upgrade to iOS 9 on my Air because it will make it slower (other topic, please don't discuss if possible :D)

    • Called the Apple support, they understood that I don't want to install iOS 9 and told me I should find my older versions of Pages for Mac on Time Machine, or ask someone who has an older version to send it to me


    The thing is, I don't have time machine. I've used a recovery software to find the old version, but it's broken sadly. Been too long I guess and parts have been overwritten.

    Now my question is, if anyone has version 5.5.3 of Pages. I know that this version will work 100%! It would be great if it wasn't a torrent also. :)


    It's quite annoying as I have an exam tomorrow, I'm writing things on my Mac, and was hoping I could have it on my iPad for later today, or during the day tomorrow before the exam, to read it in the subway for example or in bed. As always, it happens when I need it the most. I guess I'm unlucky…

    Thanks! :)
     
  2. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
  3. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #3
    Yeah that's too old, I know that you can then update it, but it would update to the latest version. What I need is 5.5.3 (which is from around April 2015 I believe) or one of the versions before of that year or from 2014 maybe!
     
  4. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #4
    You may be able to install that, then download an updater from Apple support.
     
  5. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #7
    Version 5 and later of Pages were only ever available through the App Store, so there won't be any downloads available.
    Since Pages is a paid application and is only sold in the App Store, it's likely there will be some difficulty in getting an obsolete copy of Pages; it won't be through any legitimate channels.
     
  7. Jardins de Vin, Mar 7, 2016
    Last edited: Mar 7, 2016

    Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #8
    Yeah there doesn't seem to be anything after version 3 in there.

    And yes, I don't think I'll find it anywhere in the web, that's why I am asking here. Over phone support they suggested my asking someone who has it, and that it is okay if they send it to me. Like I said, it was actually them (twice, two different people) who suggested me to do that. Since I own it legally I guess they are okay with it.

    Of course I don't want it to be cracked or whatever, it should be downloaded from the App Store. :)

    So in case someone has quick internet… and some time… and is willing to help :D Shoot it over. :D


    Edit: I found a temporary solution which is to save the document on the Mac as a Pages 09 document. Now I can have it and read it on my iPad. Of course this is just temporary, especially with iCloud and all that stuff it wouldn't be practical to have to go on the Mac each time to save the document as a Pages 09 document again, etc. etc. But I'm writing this down for all of those who may have the same problem, who may be reading this (some day maybe) but not writing here.
     
  8. charlyham macrumors regular

    charlyham

    Joined:
    Jun 30, 2012
    #9
    I have version 5.2.2 if that will work for you
     
  9. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #10
    Since it's not urgent anymore (can convert to PDF or use Pages 09 format temporarily) I don't want you to do all the extra work for nothing, and risk it may not work. I would of have been wasting your time. I'd test it, but to not waste anyone's time I'd prefer if it was version 5.5.3 straight away! But I appreciate your help very much!
     
  10. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #11
    Still nobody who got 5.5.3? :)

    Talked to Apple again today. They can not send me 5.5.3 because they don't have access to it, they have access to the same apps as us in the App Store. They told me (again) to ask a friend or someone who has 5.5.3 to send it to me eventually!

    It would be very kind if someone had it. :)
     
  11. calderini macrumors newbie

    Joined:
    May 6, 2004
    #12
    Yeah. I thought about it,(the re-set thing) but had no pressing need to do so until I saw your post. Sounded like you may need this in a hurry. And I would have only posted rants about being forced to build a Hackintosh because apple refuses to GIVE ME WHAT I WANT, lol.

    WRC
     
  12. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #13
    I actually already wondered if you re-registered just for that, I had looked up your old account and in fact you've been here for quite a while! Seriously, thanks :)

    And I know what you mean. That's just Apple, haha.
     
  13. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #15
    Thanks so much! It worked! I can sync files, and everything seems to work pretty much. Weirdly enough, in the Finder, in the preview windows, it still stays "Version 5.6.1". Same thing in the information window of the app. In "About Pages" it says 5.5.3. It looks like this information is taken from somewhere else!

    But the most important thing is that I can use it with my iPad again, and sync files. Now all my "new" files can't be read anymore (it tells me I need a newer version of pages, what else…) so I have to open them with the new version, save them as Pages 09 documents, and then re-save them in the 5.5.3 format. Apple, y u do this to me? :) I know you'd prefer if I updated my iPad so it would lag like ****, so much that I would have to buy a new one. Nice try Apple, nice try…

    Calderini had sent me the Pages app as well, but for some reason, it said the file was damaged. We don't know why. But either way, I just want to say THANK YOU to both of you! :) You saved me.
     
  14. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #16
    Hi guys,

    this time I noticed that on the MAC it would tell me that I need to update Pages in order to open a specific document. Before that, I've only received this message on the iPad, when I tried to open a document that was modified on Mac. So basically, the newer version of Pages on Mac did something to the document so that I couldn't open it on the iPad. That's why I asked for an older version of Pages on the Mac.

    So far, everything worked fine. Document from Mac could be opened on iPad, modified document on iPad could be opened on Mac, etc.

    Now suddenly on the Mac, it tells me I need a newer version to open that document. I don't get it.

    So I kept a newer version of Pages, opened it there, saved it as Pages 09 document, reopened it with the old Pages version (5.5.3) and saved it as version 5.5.3. A real pain.


    Does anyone know if there's any system files I have to delete in order to avoid this message? Thank you so much. :)
     

Share This Page