Can Apple / ATT alter Bootloader?

Discussion in 'Jailbreaks and iOS Hacks' started by gogel-geek, Oct 15, 2009.

  1. gogel-geek macrumors newbie

    Joined:
    Oct 14, 2009
    Location:
    Edison, NJ USA
    #1
    Simple question, but I can't seem to get a clear answer searching the forums.
    Can Apple / ATT alter the Bootloader Version via a firmware or network update or is it burned into a ROM at the factory and permanent?

    I'm lucky enough to have a 3G iPhone (Firmware 3.0) with Bootloader 05.08 which Fuzzyband will work with to lower the baseband version to ICE2-04.26.08 so that T-Mobile can be used as a carrier. Fuzzyband will not alter the baseband if the bootloader is 05.09 or higher.

    Please clarify!
    Thanks in advance
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    You are good to go forever, until Apple comes out with a Firmware that interferes with Fuzzyband app working (like causes it to crash) But it can probably be updated to work with newer firmwares.

    But your bootloader will never be changed.
     
  3. gogel-geek thread starter macrumors newbie

    Joined:
    Oct 14, 2009
    Location:
    Edison, NJ USA
    #3
    Thank you, lets hope that fuzzyband is updated to work with newer bootloader versions in the near future.

    Are there any advantages to upgrading my 3G firmware from 3.0 to the newest 3.1.2 since this should not have any effect on my unlock?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Not much new in 3.1/3.1.2 unless you want some app store apps that require 3.1

    You do lose tethering in 3.1

    I know I would never upgrade my firmware above the current 3.1.2 unless someone verifies Fuzzyband still works in the newer firmware. You never know when the developer might discontinue support.
     

Share This Page