Can connect to router but internet has stopped working

Discussion in 'Mac Basics and Help' started by hkhamza, Apr 13, 2008.

  1. hkhamza macrumors newbie

    Joined:
    Apr 13, 2008
    #1
    It seems that many people have been having the same problem but I couldn't find any solutions. I use a router to connect to the internet and everything has always been smooth up till today.

    The problem is this - my MBP sees the router and connects to it with a very strong signal, however I no longer get a valid IP address (I get 169.254.213.18) and cannot connect to the internet or access my router's homepage.

    I run latest version of Tiger with all the latest updates, the last Airport update was 27th March, I could connect to the internet fine after installing that update. The problem only started today. Have not installed any new software recently or changed any settings on my mac or my router, just woke up and found that I can no longer access the internet.

    Things I have tried which haven't solved the problem:
    - Reset my router and all its settings
    - Rebooted my MBP several times
    - Tried different browsers
    - Unplugged and replugged all wires connecting the DSL modem and router
    - Tried a direct ethernet cable to my router, internet works, so I guess the problem isn't the router?

    Would appreciate all the help. Thanks in advance.
     
  2. misterredman macrumors 6502a

    misterredman

    Joined:
    Oct 3, 2007
    #2
    Are you using DHCP or did you set the IP manually on your mac?
    Are you using some kind of security for the wireless connection?
     
  3. hkhamza thread starter macrumors newbie

    Joined:
    Apr 13, 2008
    #3
    Using DHCP.

    Used basic WEP security before the problem occurred but it's currently open since I've reset my router several times.
     
  4. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #4
    Like misterredman says, check that the TCP/IP in Network in System Preferences is set to Using DHCP. You will see that next to 'Configure IPv4'.

    The IP will show on the line underneath.

    If it is still stuck after, try changing DHCP to Manually or BootP and hit Apply Now. Once it does apply, change it back to DHCP and apply. I've done this before to reset the IP address.

    I know, too complicated.

    jodelli
     
  5. hkhamza thread starter macrumors newbie

    Joined:
    Apr 13, 2008
    #5
    Haha nope not complicated at all, I actually already tried that a few times, just tried it again (changing to BootP and Manually then back to DHCP). Still same problem. Thanks though!
     

Share This Page