Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

aaronhead14

macrumors 65816
Original poster
Mar 9, 2009
1,223
5,284
Thinking about adding a regular non-MPX Radeon RX 6900 XT to run side by side with my current Radeon Pro Vega II MPX Module. Are there any issues with doing this?
 

prefuse07

Suspended
Jan 27, 2020
895
1,061
San Francisco, CA
Multiple accounts with the end resolution being: remove MPX

giphy.gif
 
  • Like
Reactions: ZombiePhysicist

aaronhead14

macrumors 65816
Original poster
Mar 9, 2009
1,223
5,284
I'd be curious if there's anyone else on here who hasn't had problems adding a 6900 XT to use alongside their Vega Pro II. Anyone?
 

Rian Gray

macrumors regular
Jul 13, 2011
199
45
NJ, United States
I mean, I had 580x along side with 6900xt, and I didn't have any major issues with it. I've removed the MPX module only after reading this thread, so wish me luck finding out the differences.
 
  • Like
Reactions: aaronhead14

aaronhead14

macrumors 65816
Original poster
Mar 9, 2009
1,223
5,284
Follow-up question: Would adding a W6900X MPX GPU cause the same issues alongside a Vega II as the non-MPX PCIe GPUs? Or should it play nice with the Vega II since they're both MPX?
 

prefuse07

Suspended
Jan 27, 2020
895
1,061
San Francisco, CA
^that should work fine.

I think the issue is when you have an MPX module + (non MPX) AMD GPU, the 7,1 puts priority on the MPX, so if you are using the AMD GPU as your primary card with the MPX still installed in the machine, the 7,1 still tries to go for the MPX first (and load the MPX graphics driver), despite monitors being hooked up to only the AMD card...

So the machine loads the MPX graphics drivers instead, even if your AMD drivers are more recent, which causes a lot of issues with games and with the OS in general

such as this:
graphics-drivers-out-of-date-message-v0-wfurd78126mb1.png.png


This is just my theory based on my experience in both Windows and macOS. Once I removed my MPX module, my issues went away completely in both OS'. Again, check the thread I linked above. There is also a link to another thread that I created showing the issues I started having in both Windows and macOS, which went away, as soon as I completely removed my MPX and kept just my AMD card. The testimonials from other members also support what I am saying.
 
Last edited:

Korican100

macrumors 65816
Oct 9, 2012
1,198
609
I'd be curious if there's anyone else on here who hasn't had problems adding a 6900 XT to use alongside their Vega Pro II. Anyone?
i dont have any problems. all your monitors should be plugged into the 6900xt. I had some issues when I just had one or none of my monitors going into the 6900xt. When i put both in the 6900xt, it worked great.

using in FCPX, the 6900xt is def faster.
going to bootcamp into steam later and try out some gaming.
 
  • Like
Reactions: aaronhead14
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.